Route incorrect on VPN connection

Got a problem with Viscosity or need help? Ask here!

rickh925

Posts: 1
Joined: Sun Dec 03, 2023 7:49 am

Post by rickh925 » Sun Dec 03, 2023 8:06 am
I've been using Viscosity for 7 or so years on a Mac and recently switched back to Windows. I have had so much trouble with the same 10-15 OpenVPN servers running on pfSense that work perfectly with the Mac client. The main problem is that the 0.0.0.0 route associated with the wireless or ethernet LAN adapter continues to remain active with a lower metric than the 0.0.0.0 route on the OpenVPN adapter. The other issue is that subnets from the pfSense server are not pushed to the Windows client. This probably wouldn't be a problem if the default route was to the VPN server, but since it is not, I cannot work at all without doing a route delete after connecting. The OpenVPN Connect client works perfectly, but I prefer the Viscosity client since I've used it for so long.

I even set the client configuration for any of the servers to "Send all traffic over VPN connection" which I would hope would remove the 0.0.0.0 route to the LAN/WLAN interface, but it does not.

Finally, I am running as a standard user. Hopefully that isn't a problem as running as an admin is just a no-go. I have admin credentials I can use if needed for various tasks, but do not ever run as an admin day-to-day.

Any help with this? I'm so frustrated at how long it takes to get work done by having to do the manual route updates.

Rick

Aaron

Posts: 25
Joined: Wed Nov 30, 2022 2:53 pm

Post by Aaron » Mon Dec 04, 2023 6:54 pm
Hi Rick,

A default/0.0.0.0 route remaining in place for other network interfaces isn't unexpected, and doesn't mean it's getting used as the global default route. If you've configured your VPN connection for all network traffic to be routed over it, then you can follow the steps here to check whether this is the case:
https://www.sparklabs.com/support/kb/ar ... connection

You don't typically want to be modifying the default (0.0.0.0) route. You'll want to use "redirect-gateway def1" if pushing the All Traffic setting from the OpenVPN server (or Viscosity's "Send all traffic" option if setting it locally), which will override the default route on both macOS and Windows. Make sure the "def1" flag is included (Viscosity will include it by default).

If you're still stuck, please post the items listed in the following article (or email them to us if you'd prefer not to post them publicly) and we will take a look for you:
https://www.sparklabs.com/support/kb/ar ... ort-staff/

Regards,
Aaron
Web: https://www.sparklabs.com
Support: https://www.sparklabs.com/support
Twitter: https://twitter.com/sparklabs
2 posts Page 1 of 1