Unable to connect - VPN system not started

Got a problem with Viscosity or need help? Ask here!

davidandreasen

Posts: 2
Joined: Thu Nov 21, 2019 1:37 am

Post by davidandreasen » Wed Dec 22, 2021 11:23 am
Hello,

I have been getting these errors when trying to connect on a Windows 10 system with Viscosity 1.10.1. I've tried uninstalling and whitelisting the Viscosity programs in Windows Defender with no success. Log sample is below. Any ideas?
Code: Select all
Dec 21 5:50:47 PM: State changed to Connecting
Dec 21 5:50:47 PM: Viscosity Windows 1.10.1 (1749)
Dec 21 5:50:47 PM: Running on Windows 10 2009 (19042) 64 bit
Dec 21 5:50:47 PM: Running on .NET Framework Version 4.8.04084.528372
Dec 21 5:50:48 PM: Checking reachability status of connection...
Dec 21 5:50:48 PM: Connection is reachable. Starting connection attempt.
Dec 21 5:50:48 PM: Interface Type: ViscTunTap
Dec 21 5:50:48 PM: Bringing up interface...

The OpenVPN subsystem could not be started. Please check the following:
- Check for any error messages above this notification.
- Ensure ViscosityService is running.
- Make sure the configuration is valid

Dec 21 5:50:50 PM: State changed to Disconnecting (OpenVPN System Failure)
Dec 21 5:50:50 PM: OpenVPN has exited. Exitcode = -1073741790

Eric

User avatar
Posts: 1132
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Dec 22, 2021 11:57 am
Hi davidandreasen,

The issue here is the exit code -1073741790 (or 0xC0000022). This exit code means OpenVPN is being denied access to system resources. Normally we would point straight to AV software causing this, however as you have already mentioned Windows Defender, we will assume you don't have other third party AV software installed.

First, please try running OpenVPN from a command prompt:

"C:\Program Files\Viscosity\Resources\OpenVPN\openvpn.exe" --version

If this crashes, it should give you an error message that can be acted on as to what is going on.

If it runs, the next steps are to check the Event Viewer when Viscosity is failing to connect. Please try a connection again then check the event viewer for any warnings or errors around the time of the exit - https://sparklabs.com/support/kb/articl ... nt-viewer/

If there is nothing here, I'm afraid the issue is most likely related to file permissions on the system. Something has probably changed file permissions on either Program Files or the Windows directory (usually a virus/malware or a badly designed application), which is denying access to files for the System or Local Service inbuilt user. You can try changing the Viscosity Service to run as a local administrator to rule this in or out. We don't recommend running as this user long-term though, I'm afraid the only easy fix is to reinstall Windows if the above is the case.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1