Creating unneeded adapters

Got a problem with Viscosity or need help? Ask here!

n8chavez

Posts: 19
Joined: Sat Aug 15, 2015 3:53 pm

Post by n8chavez » Sat Mar 20, 2021 7:32 am
For whatever reason, Viscosity keeps creating adapters, in this case tun, for every server despite me telling it not to. I've checked the "use single network adapter for all connections" option, and told each connection to not create a network adapter but it still does. It never used to do this. How can I get all the servers to use one Viscosity tun? I'm using version 1.9.2 (1713)

Eric

User avatar
Posts: 1073
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Mon Mar 22, 2021 11:23 am
Hi n8chavez,

Please uninstall Viscosity, this will remove all existing adapters. Make sure you don't remove your settings and connections.

Then reinstall Viscosity from our website, ensure that Use single network adapter is ticked, and then connect to a connection. Once that connection is connected, try connecting to a second and you shouldn't be able to.

https://sparklabs.com/viscosity/download/

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

n8chavez

Posts: 19
Joined: Sat Aug 15, 2015 3:53 pm

Post by n8chavez » Mon Mar 22, 2021 2:25 pm
I think you misunderstand my issue. I configured Viscosity to not create a tun adapter for every server connection, to use one for all of them. However Viscosity seems to be ignoring this and instead creates an adapter named after each and every server I have. This is what I'd expect if Viscosity was set to defaults. But it is not. The issue is not that I can (or want to) connect to multiple servers at once, it's that it creates adapters when it's been configured not to. I want one adapter because it makes it easier for scripting, and YogaDNS rules. I need one adapter, not many.

Eric

User avatar
Posts: 1073
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Mar 23, 2021 12:36 pm
Hi n8chavez,

I have understood the issue you are facing. Please follow the instructions from my original reply to clear the multiple adapters from your system, reinstall Viscosity, ensure Single Adapter Mode is enabled, and then ensure Single Adapter Mode is functioning correctly.

Please also ensure the "Don't create a network adapter for this connection" option is *not* ticked. If it is and the connection has a dev-node that is not the single adapter, Viscosity will attempt to repair that dev-node, which will most likely result in a new adapter being created. This may be what is causing the issue you are seeing.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

n8chavez

Posts: 19
Joined: Sat Aug 15, 2015 3:53 pm

Post by n8chavez » Fri Mar 26, 2021 10:19 am
I got it to work. I followed your directions. However, they did not exactly work. TAP adapters were created for every server I have listed. After importing the last server, adapters were created when I tried to connect. But I did get it to work by deleting every adapter but one. After that all the connections worked fine using the one adapter.
5 posts Page 1 of 1