Problems with Asus Router and LZ4-V2

Got a problem with Viscosity or need help? Ask here!


Posts: 2
Joined: Thu May 30, 2019 1:41 am

Post by TheUntouchable » Thu May 30, 2019 1:51 am
Hi guys!

Thanks a big thank you for that really nice client, a lot of addional features compared to the original openvpn client!

Sadly I have a little problem with my current setup.

I am using the following devices:

Router: Asus RT-AC88U with asuswrt-merlin (latest)
Device: Asus UX303LN with current release or latest beta of Viscosity

If I am using LZ4-V2 for compression on the Asus OpenVPN server, I am able to connect with Viscosity, but no traffic is possible:
Mai 29 17:30:37: Status auf Verbunden geändert
Mai 29 17:30:46: Bad compression stub (swap) decompression header byte: 42
Mai 29 17:31:01: Bad compression stub (swap) decompression header byte: 42

This behaivour doesn' change if I choose LZ4 instead of auto in the configuration of Viscosity.
If I am trying the same from my android phone with "VPN Client Pro" everything works without any problems.

I am using the same ovpn file on both devices.

If I am switching back to LZ4 on the OpenVPN server, the connection works.

Anything I can do here?

Thanks in advanced!

Kind regards,


User avatar
Posts: 1090
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Thu May 30, 2019 11:33 am
Hi Michael,

LZ4-v2 is still considered experimental so the Viscosity editor doesn't support it at this time. Compression in general with OpenVPN isn't recommended -

If you'd like to use it still, set Compression to Off in Viscosity, from here you have two options.

You can set the following in Viscosity in advanced:
compress lz4-v2

However next time you edit your connection and Save it, Viscosity will override the lz4-v2 setting.

Alternatively, you can push this option from your server by adding the line to your config or your routers advanced OpenVPN settings:
push "compress lz4-v2"

Let us know how you get on.

Eric Thorpe
Viscosity Developer



Posts: 2
Joined: Thu May 30, 2019 1:41 am

Post by TheUntouchable » Thu May 30, 2019 11:58 pm
Hi Eric,

Thank you very much for your quick and detailed answer!

After reading your linked article I decided to disable compression completely and use my VPN like this. At the moment it seems to be more secure and the compression is not supposed to bring that much to VPN anyway.

Thanks anyway and have a nice day!

3 posts Page 1 of 1