Version 1.9.4 DNS Issues

Got a problem with Viscosity or need help? Ask here!

Eric Online

User avatar
Posts: 1116
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Sep 22, 2021 9:02 am
Hi rps,

If you are pushing no routes, no traffic should be going through the VPN thus DNS not resolving shouldn't be an issue in this case. The users local DNS servers should be answering connections. The exception here is if you are forcing users to Full DNS, of which case the local DNS servers will not be used and the user will fail all DNS requests as none will be available.
The DNS servers provided by the VPN can potentially be identical to the DNS servers provided via DHCP on the LAN interface.
In this scenario, DNS requests will only go to which ever interface has the most accurate route. If you are set to Full DNS, but the local interface has the closer matching route for the DNS server, all DNS will fail. If you are set to Split DNS but the VPN has the closer matching route, only split-dns lookups will work. The log will show how DNS is setup as well as what is reachable - https://sparklabs.com/support/kb/articl ... envpn-log/

In this setup of selectively pushing routes, it may be better selectively pushing DNS Modes as well or instead. In the scenario where you push no routes for the user, you would be better off also pushing a DNS Mode of 'disabled'. In a scenario where you want all the users DNS to go through the VPN, you would be better off pushing a DNS mode of 'full'. Information on pushing DNS modes can be found here - https://sparklabs.com/support/kb/articl ... h-dns-mode

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

dragusalexandru

Posts: 2
Joined: Tue Sep 28, 2021 8:48 pm

Post by dragusalexandru » Tue Sep 28, 2021 8:50 pm
same problem

Eric Online

User avatar
Posts: 1116
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Sep 29, 2021 8:48 am
Hi dragusalexandru,

Could you please provide a the following and we can take a look - https://sparklabs.com/support/kb/articl ... ort-staff/

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

dkaczmark

Posts: 3
Joined: Tue Mar 29, 2011 11:04 am

Post by dkaczmark » Tue Oct 19, 2021 5:51 am
Eric,

Same issue regarding DNS on 1.9.4 on Windows 10 21H1.

In our instance, we push a DNS server and DNS Search domains to clients.

When using v1.9.4, server logs indicate that no pushed DNS server is found and reverts back to the locally system configured DNS.

With v1.9.3, the logs correctly indicate that DNS is set to 'Split' and Split Domains are correctly reflected.

I'm happy to provide redacted configuration and logs if you can provide a private means of sharing them.

Many thanks

Eric Online

User avatar
Posts: 1116
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Oct 19, 2021 11:10 am
Hi dkaczmark,

You can find our email address here - https://sparklabs.com/support/#contact

If you could send us the following, we can take a good look - https://sparklabs.com/support/kb/articl ... ort-staff/

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
15 posts Page 2 of 2