force vpn to use network adapter

Got a problem with Viscosity or need help? Ask here!

asdffdsa6131

Posts: 30
Joined: Sat Feb 23, 2019 12:15 pm

Post by asdffdsa6131 » Fri Jan 29, 2021 3:29 am
hello and thanks,

how can i force a vpn to use a certain network adapter such as my wifi , not my wired ?

i tried to find the answer here
https://www.sparklabs.com/support/kb/ar ... -commands/
https://www.sparklabs.com/support/kb/ar ... nnections/

thanks,
david

Eric

User avatar
Posts: 1090
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Fri Jan 29, 2021 10:03 am
Hi David,

You can use the local command. Edit your connection, go to the advanced tab and add the following:
local <IP Address of adapter to bind to>

You will also need to go to the Options tab and untick "No Bind" if it is ticked.

For most connections you should also add a route to your configuration, something like:

Destination: Your VPN Server IP
Mask/Bits: 255.255.255.255
Gateway: Custom-<Gateway of the adapter to use>

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

asdffdsa6131

Posts: 30
Joined: Sat Feb 23, 2019 12:15 pm

Post by asdffdsa6131 » Fri Jan 29, 2021 10:31 am
thanks that worked.

sorry, i read that entire help page and missed local
3 posts Page 1 of 1