Can't connect to VPN

Got a problem with Viscosity or need help? Ask here!

Zane Prose

Posts: 1
Joined: Mon Oct 19, 2020 5:38 am

Post by Zane Prose » Mon Oct 19, 2020 5:47 am
Hello, I'm having alot of trouble connecting to my schools viscosity vpn and clearly don't know how to troubleshoot the problem :roll: .
The connection log in its entirety says:

Oct 18 12:37:16 PM: State changed to Creating...
Oct 18 12:37:17 PM: Failed to create adapter.
Oct 18 12:37:17 PM: State changed to Disconnected
Oct 18 12:37:20 PM: State changed to Connecting
Oct 18 12:37:20 PM: Viscosity Windows 1.8.6 (1682)
Oct 18 12:37:20 PM: Running on Windows 10 1803 (17134) 64 bit
Oct 18 12:37:20 PM: Running on .NET Framework Version 4.8.03761.528049
Oct 18 12:37:20 PM: Checking reachability status of connection...
Oct 18 12:37:21 PM: Connection is reachable. Starting connection attempt.
Oct 18 12:37:21 PM: No associated network adapter was found, creating one. This process may take up to a minute or two.
Oct 18 12:37:21 PM: OpenVPN 2.4.9 Windows-MSVC [SSL (OpenSSL)] [LZO] [LZ4] [AEAD] built on Jul 8 2020
Oct 18 12:37:21 PM: library versions: OpenSSL 1.1.1g 21 Apr 2020, LZO 2.10
Oct 18 12:37:35 PM: Resolving address: "ras.mines.edu"
Oct 18 12:37:35 PM: Valid endpoint found: ras.mines.edu:1194:udp
Oct 18 12:37:35 PM: WARNING: --ns-cert-type is DEPRECATED. Use --remote-cert-tls instead.
Oct 18 12:37:35 PM: TCP/UDP: Preserving recently used remote address: [AF_INET]138.67.253.42:1194
Oct 18 12:37:35 PM: UDP link local: (not bound)
Oct 18 12:37:35 PM: UDP link remote: [AF_INET]138.67.253.42:1194
Oct 18 12:37:35 PM: State changed to Authenticating
Oct 18 12:37:35 PM: WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Oct 18 12:37:35 PM: [OpenVPN Server] Peer Connection Initiated with [AF_INET]138.67.253.42:1194
Oct 18 12:37:35 PM: State changed to Connecting
Oct 18 12:37:36 PM: Obsolete option --dhcp-release detected. This is now on by default
Oct 18 12:37:36 PM: Unrecognized option or missing or extra parameter(s) in [PUSH-OPTIONS]:24: block-ipv6 (2.4.9)
Oct 18 12:37:36 PM: Awaiting new interface creation...
Oct 18 12:37:36 PM: CreateFile failed on TAP device via management.: Unknown error (errno=10035)
Oct 18 12:37:36 PM: State changed to Disconnected

I've tried uninstalling, reinstalling, deleting unknown devices in device manager, updating the client, contacting support through the school and no one has been able to help solve this issue. I thought that maybe the router or the antivirus software that I use might be blocking the connection somehow though I don't know the first thing about how to troubleshoot that. Sidenote: I can successfully connect to the vpn on my ipad with no problems and on the same wifi if that's any consolation.
Any input would be much appreciated thank you!

Eric

User avatar
Posts: 1073
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Mon Oct 19, 2020 10:55 am
Hi Zane,

Adapters are failing to be created. You mentioned you had some unknown devices in device manager? If this is the case you most likely have a problem with Windows which is preventing driver signing being checked. If this is the case, I HIGHLY recommend you reinstall Windows as this is quite the security issue.

Otherwise, we have some troubleshooting here - https://sparklabs.com/support/kb/articl ... wn-devices

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1