Windows App No Longer Starts

Got a problem with Viscosity or need help? Ask here!

richardl

Posts: 1
Joined: Thu Jun 04, 2020 7:08 am

Post by richardl » Thu Jun 04, 2020 7:21 am
I'm currently having a problem where the Viscosity GUI does not start, with no visible indication to why. When I start the app from the start menu, no window appears. Only messages in the Windows Event log show up.

I've been running Viscosity 1.8.5 since it was released on Windows 10 with no problems. On Saturday I applied the Windows 10 Feature Update to 2004, and still no problems. Today I rebooted a few times for removing VirtualBox, enabling WSL2, and installing Docker, and still no problems. I removed Docker trying to diagnose a different problem, and when I reinstalled it and rebooted, the problem had started. Looking in Windows reliability monitor, this has actually been logging crashes of ViscosityService.exe since Saturday (when I updated to 2004), but I hadn't actually noticed this (I've normally got 2 VPNs connected for work).

Whenever I start the app, I get the following 3 events in the Application Log:
--
Code: Select all
Application: Viscosity.exe
Framework Version: v4.0.30319
Description: The application requested process termination through System.Environment.FailFast(string message).
Message: 
Stack:
   at System.Environment.FailFast(System.String)
   at <Module>.‎​‪‮‬​‎‪‫‮‪‎‮‬‎‪‍‫‮‌‌‮‬‬‮‏‏‮‮()
   at <Module>..cctor()
--
Faulting application name: Viscosity.exe, version: 1.8.5.1669, time stamp: 0x5e8a9e7f
Faulting module name: unknown, version: 0.0.0.0, time stamp: 0x00000000
Exception code: 0x80131623
Fault offset: 0x00007fff71c71a7c
Faulting process ID: 0x6414
Faulting application start time: 0x01d639ec85fbd627
Faulting application path: C:\Program Files\Viscosity\Viscosity.exe
Faulting module path: unknown
Report ID: 29802500-df42-4036-8a87-c5c564fc54b4
Faulting package full name: 
Faulting package-relative application ID: 
--
Fault bucket 1162562014272629305, type 5
Event Name: CLR20r3
Response: Not available
Cab Id: 0

Problem signature:
P1: Viscosity.exe
P2: 1.8.5.1669
P3: 5e8a9e7f
P4: Viscosity
P5: 1.8.5.1669
P6: 5e8a9e7f
P7: 2
P8: 6a
P9: FatalError
P10: 

Attached files:
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER128F.tmp.dmp
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER13E8.tmp.WERInternalMetadata.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER1466.tmp.xml
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER1474.tmp.csv
\\?\C:\ProgramData\Microsoft\Windows\WER\Temp\WER1521.tmp.txt

These files may be available here:
\\?\C:\ProgramData\Microsoft\Windows\WER\ReportArchive\AppCrash_Viscosity.exe_6f68d8e18a347c1629cccddf51da5f01e4ca14d_7396dce5_d68b325f-95b5-498e-b76b-a526ca327c00

Analysis symbol: 
Rechecking for solution: 0
Report Id: 29802500-df42-4036-8a87-c5c564fc54b4
Report Status: 268435456
Hashed bucket: 30af148afaf0cc1530223ffe12152a39
Cab Guid: 0
I've currently had to go back to an alternative OpenVPN client until this is solved. Any suggestions would be welcome!

Eric

User avatar
Posts: 1127
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Thu Jun 04, 2020 10:54 am
Hi richardl,

FailFast errors are a failure in the underlying frameworks of the system. Generally, this means .NET is damaged, but I'm afraid knowing for sure is next to impossible. If possible, please run a repair on the system by reinstalling Windows. If this is not possible, the first thing to try is a repair on .NET - https://www.microsoft.com/en-us/downloa ... x?id=30135

If you are running intrusive developer tools or AV/Firewall/Security software these can also cause the issue. You may have some security software which has not handled the update to 2004 well. It sounds like it is more likely however that something you have installed or uninstalled has modified or removed some system files it shouldn't have in this case.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1