Viscosity cannot connect because it cannot resolve DNS

Got a problem with Viscosity or need help? Ask here!


Posts: 4
Joined: Sun Apr 08, 2018 3:04 am

Post by dgfdgfdfgfgdfgfdDDD » Sat Dec 28, 2019 7:18 pm
I recently tried my VPN provider's own app because I wanted to see if it had some features I needed. However it didn't and so I went back to usung Viscosity. But now whenever I try to connect, it cannot resolve the VPN remote server Address anymore. Its weird because it works just fine in the browser, no problems with DNS. My DNS server is on my local network (I use Pi Hole) so I tried specifying its address under Networking DNS settings but it had no effect. Then I tried referenceing the servers directly by IP instead and that did work.

Why isn't DNS lookups working in Viscosity?

I think it is the same issue that I had a while back, I don't remember how I fixed it:


User avatar
Posts: 1073
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Fri Jan 03, 2020 12:20 pm

As mentioned in the post you linked, generally when Viscosity can't resolve an address but nslookup or other applications can, the issue is a firewall or AV software blocking Viscosity or ViscosityService from making a connection to lookup an address.

Alternatively, what simply may be happening is local lookups are working as they are cached. As a first step, we recommend simply restarting your PC to clear any caches as this may reveal the problem in itself. If you're still stuck, please let us know.

Eric Thorpe
Viscosity Developer

2 posts Page 1 of 1