"Adapter already in use ..."

Got a problem with Viscosity or need help? Ask here!


Posts: 16
Joined: Fri Mar 16, 2018 5:11 pm

Post by tek » Wed Sep 26, 2018 12:35 am
Background: win 10 home; connect to several VPN servers, but only one at a time, using viscositycc via scripts.

I'm running into the following issues related to network adapters, and here's what I've tried:

I started off using single-adapter-mode, waited for a connection's status to say "connected" before using, disconnected the connection and waited for its status to say "disconnected" before initiating another connection. This should have worked, but I consistently got "adapter already in use" dialogs.

To address that I issued a "taskkill -f openvpn.exe", wait 10 seconds before initiating a new connection, and that worked for a while, but recently I've again been seeing the "adapter already in use" message. So I added a 'netsh interface set interface "Viscosity" admin=disable' (with and without a subsequent "enable") after killing the openvpn process, but still get the "adapter in use" dialog.

So I went the adapter-per-connection route: uninstalled viscosity, reinstalled, checked "create adapter on import", and imported connections. Here's what I see:

a) even though I check create-adapter-on-import, no adapters are created when I import a folder of connections. Does this work only for per-connection-import?

b) when viscosity tries to create a new adapter at run-time, I get a dialog saying "you have an active connection. viscosity will need to close this connection bla bla to create a new adapter. do you wish to continue?" I don't see an option to say "do this always, and don't ask again". Am I missing something?

These dialogs are really hampering my being able to use viscositycc efficiently.

Please advise

Thank you


User avatar
Posts: 969
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Sep 26, 2018 11:53 am
Hi Tek,

As we've mentioned in the past, Viscosity isn't designed for your use case. As you have such a large number of connections it can take some time for the shutdown routines to finalise after disconnecting a connection, this is most likely why you are seeing this dialog still appear for a while after a connection has disconnected, this is just a limitation of having such a large number of connections.

a) This is correct, adapters are not created when importing more than one connection at a time.

b) There is no option to always do this as Viscosity was not designed to cycle through connections constantly, the vast majority of users will never see this dialog. We will look into adding this as an option though.

Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs


Posts: 16
Joined: Fri Mar 16, 2018 5:11 pm

Post by tek » Wed Sep 26, 2018 12:33 pm
Thanks, Eric -- that answers my questions.

I'll try increasing waittime in single-adapter mode, and writing an auto-it script or some such to automate importing configs one by one in multiple-adapter mode.

My seeming-bellyaching aside ViscosityCC remains the best off-the-shelf VPN client I've found thus far, and I look forward to versions that may cater to my sort of usage.



Posts: 16
Joined: Fri Mar 16, 2018 5:11 pm

Post by tek » Wed Oct 03, 2018 11:18 pm
FYI update: I went back to using a single adapter, disconnect connection and wait for disconnected message, kill openvpn, don't bother disabling/enabling adapter, wait for 20 seconds ... and have gotten very few adapter-in-use messages since. The ones I did get were during the trial-error period of arriving at the sequence above.
4 posts Page 1 of 1