Beta 1.9

Got a problem with Viscosity or need help? Ask here!

chris_childerhose

Posts: 4
Joined: Thu Sep 24, 2020 2:16 am

Post by chris_childerhose » Thu Sep 24, 2020 2:23 am
Installed Beta 1.9 on Windows Insider 20215 and it broke Viscosity. Connections would not connect and devices in the device manager had issues with the new driver. Had to revert to 1.8.6 to get working. :cry:

Unsure if we need to do a clean install of the beta or not but would need the link to download and test it.

Eric

User avatar
Posts: 991
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Thu Sep 24, 2020 10:35 am
Hi Chris,

Thanks for the feedback. If possible, could you please update to the beta again and let us know what the status of the Virtual adapter is in device manager? It should appear in Properties, you may need to enable the device to get a status other than Disabled.

Once done, you can simply revert to the legacy driver if you need to by selecting it in Preferences -> Advanced -> Adapter Type and connecting again.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

Eric

User avatar
Posts: 991
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Thu Sep 24, 2020 5:11 pm
Hi Chris,

We've grabbed the latest insider Dev channel build and confirm there is a problem with the insider builds with our new driver. We'll add it to our list to investigate. In the mean time, you can switch to the old driver with the drop down in Preferences -> Advanced and be able to use the latest beta with the old driver. The old driver will not be removed in 1.9 release.

This does not effect Windows 10 2004 or 20H2 Beta.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

chris_childerhose

Posts: 4
Joined: Thu Sep 24, 2020 2:16 am

Post by chris_childerhose » Thu Sep 24, 2020 10:42 pm
Glad to hear and I have used the option for the old driver and it is working. I look forward to a fix and testing.

Please reply here so that I know when a possible fix is released.

chris_childerhose

Posts: 4
Joined: Thu Sep 24, 2020 2:16 am

Post by chris_childerhose » Tue Sep 29, 2020 11:17 pm
Tried Beta 2 but still no fix so using Legacy until there is one for the new adapter driver.

Eric

User avatar
Posts: 991
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Sep 30, 2020 2:44 pm
Hi Chris,

There appears to be some substantial, and importantly, undocumented (so far) changes to the kernel framework in Windows 20xxx Dev channel insider builds, with further changes build to build. Unfortunately as this is bleeding edge, we need to wait until these changes are stabalised and documented until we can invest any serious time, this will most likely be when these changes are moved into the beta builds and Microsoft release a pre-release WDK rather than the nightlies, probably around Redstone time. We'll certainly post an update here for you when we think this is the case and have an updated driver in our beta that should work on the dev channel builds.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

chris_childerhose

Posts: 4
Joined: Thu Sep 24, 2020 2:16 am

Post by chris_childerhose » Wed Sep 30, 2020 10:39 pm
Thanks Eric. Yeah figured as much but if you need someone to test let me know happy to help. :D
7 posts Page 1 of 1