[Bug] Spaces in the path to pkcs11 library on Mac OS X

Suggestions/comments/criticisms are welcome here


Posts: 1
Joined: Mon Dec 16, 2013 4:40 pm

Post by Mirron11 » Mon Dec 16, 2013 5:01 pm
Hi there!
First of all, I'd like to thank Sparklabs team for making a great software. Viscosity is one of the easiest and the most convinient ways to perform VPN connection.
Fortunately, there are still things to do on the way to excellency. There seems to be a bug in authentication setting panel. When authentication is performed using PKCS11, there is a field to input path to PKCS11 library -- it seems not to support spaces. I've tried these patterns:
<path/to/library/with spaces/pkcs11.dylib>
<"path/to/library/with spaces/pkcs11.dylib">
<"path/to/library/with\ spaces/pkcs11.dylib">
<path/to/library/with\ spaces/pkcs11.dylib>
but neither has worked for me.
I'm looking forward to using spaces in the path strings freely in the next version of Viscosity.


User avatar
Posts: 2076
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Thu Dec 19, 2013 3:07 am
Hi Mirron11,

Clicking the "Add" button and selecting your PKCS#111 provider file will automatically add the path in the correct format. This will have no trouble dealing with spaces in the path. I'd recommend clearing the field with what you have now, clicking the Add button and selecting your provider file, clicking Save, and then see how you get on.

However we did pick up a bug in version 1.4.6 where while the above should work without a problem, subsequent edits could result in provider paths with spaces being stripped. This has been fixed up in version 1.4.7, which I encourage you to try (although I would recommend going through the Add process above before trying to connect to be sure the path is formatted correctly).

Thanks for your feedback! Please let us know if you still have any issues with PKCS#11.

James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1