UDP and viscosity 1.4.1

Got a problem with Viscosity or need help? Ask here!

maxime63

Posts: 3
Joined: Wed Aug 15, 2012 1:38 am

Post by maxime63 » Fri Aug 17, 2012 8:53 am
Hello,

I like to know if among those under 1.4.1 viscosity can access the Internet from the vpn UDP?
At home I can not access the Internet from a udp port by TCP against everything works.
I tested the windows version of viscosity and there it works both TCP UDP that I have never had this problem with previous versions of viscosity.
Thank you for your answers.

James

User avatar
Posts: 2102
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Thu Aug 23, 2012 8:11 am
Hi maxime63,

I'm afraid I'm not exactly sure what you mean - are you saying you are able to connect to your VPN connection, but you are unable to browse the Internet while connected? If so, did that start happening after you upgraded to version 1.4.1, or has it always been occurring? Are there any messages or warnings on the OpenVPN log?

It may also be worth trying the latest beta version to see if that solves the problem for you:
http://www.thesparklabs.com/forum/viewt ... p=134#p134

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

maxime63

Posts: 3
Joined: Wed Aug 15, 2012 1:38 am

Post by maxime63 » Thu Aug 23, 2012 8:36 am
That's right, the VPN connection is established, but can not surf the internet, it looks like a DNS resolution problem, this problem occurs only with UDP, TCP operates perfectly.
Level of viscosity logs I do not have specific error messages.
To operate properly the latest version 1.4.1 TCP I had installed the latest version of openvpn 2.3 on my server and then recreate the SSL certificate because I had errors TLS connection.
Before the latest 1.4.1 viscosity, I had no problem connecting with UDP, the evidence, the Windows version of viscosity with my setup UDP works.
I think with the latest beta version of 1.4.2 viscosity it will work since you can revert to openvpn 2.2, as soon as I've done testing, I want you informed.

maxime63

Posts: 3
Joined: Wed Aug 15, 2012 1:38 am

Post by maxime63 » Thu Aug 23, 2012 8:47 am
After doing tests, the UDP protocol on port 500 does not work with the latest beta version, either by selecting openvpn 2.2 or 2.3 in the advanced preferences, I have no error message in the connection vpn, it is connected but can not reach internet, apparently DNS resolution problems.

mark143

Posts: 19
Joined: Wed Aug 03, 2011 6:58 am

Post by mark143 » Sat Sep 15, 2012 5:38 pm
Installed the latest version of viscosity. I think we may have the same problem. UDP port 53 is no good for regular internet surfing. BitTorrent on the other works very fast & stable.

No problem as well in TCP
5 posts Page 1 of 1