Problem accessing share via VPN

Got a problem with Viscosity or need help? Ask here!

Singer7569

Posts: 2
Joined: Thu May 09, 2024 8:22 pm

Post by Singer7569 » Thu May 09, 2024 8:36 pm
Hallo. I have a problem with a Macbook pro (Sonoma 14.3).

The Mac uses OpenVPN to connect to the network office LAN and access a share hosted on a Synology NAS
(Viscosity 1.11.1).

Before updating to Sonoma everything was working fine, after the update the Mac cannot connect to the NAS.
If I try to mount the nas share via Finder, (smb://server_ip/share), after entering the credentials it hangs forever.
Nothing has changed on the LAN/firewall side and other Mac users connect fine via VPN using Viscosity ( five clients but not on Sonoma).
When the Mac is in the local network everything works fine.

I have tried to check the network connectivity to the remote network and I successfully ping the NAS ip, but I cannot connect via smb or afp, and I cannot access the NAS web interface, but I reach another LAN device via its web interface, so it looks like the problem is with the NAS only.

I have also tried to uninstall/clear the VPN configuration, use another user to access the share, clear ~/Library/Preferences/com.apple.finder.plist (it was suggested to me) but nothing.

Has anyone experienced similar problems?

As soon as the user of the Mac comes back, I will try to gather some logs, but I really can't figure what's happening.

I don't have experience with Mac so any hint will be welcome.
Thanks

James

User avatar
Posts: 2340
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Fri May 10, 2024 7:01 am
Hi Singer7569,

Being able to ping the NAS would likely rule out it being a routing or DNS issue with the VPN connection. About the only thing that could explain the problem from a VPN standpoint would be an MTU issue, but if that were the case you'd have seen the same problem prior to upgrading your copy of macOS.

I recommend checking your VPN connection log just to make sure there aren't any relevant warnings or error messages, but based on your description it sounds like it the issue is likely unrelated to your VPN connection.
https://www.sparklabs.com/support/kb/ar ... envpn-log/

You'll need to get in touch with the administrator of the NAS server and ask them to check the SMB and web logs. In particular look for any authentication errors: the problem may be that the NAS server is rejecting your connection attempts rather than a network issue.

A quick internet search also reports that macOS Sonoma has dropped support for some legacy SMB/NTLM authentication standards, which could also prevent you from connecting if the NAS server is using these. Reach out to the administrator of the NAS server and make sure it's up-to-date.

Cheers,
James
Web: https://www.sparklabs.com
Support: https://www.sparklabs.com/support
Twitter: https://twitter.com/sparklabs

Singer7569

Posts: 2
Joined: Thu May 09, 2024 8:22 pm

Post by Singer7569 » Wed May 15, 2024 2:55 am
Thanks for your answer, unfortunately I'm the network and Nas admin too :lol:
No way to understand what's happening but at least I have ruled out a VPN issue.
3 posts Page 1 of 1