Options error Temporary Directory

Got a problem with Viscosity or need help? Ask here!


Posts: 3
Joined: Tue Jun 02, 2020 8:45 am

Post by mjs » Tue Jun 02, 2020 8:54 am
Oddly enough, this was working until I registered viscosity today.

Running on a mac with Catalina 10.15.4.

Tried setting permissions using
sudo chown root:wheel /private/tmp
sudo chmod 1777 /private/tmp

I believe as of 10.15 the correct permissions are supposed to be:
drwxr-xr-x 5 root admin which is what it was already set to and verified on another 10.15.4 mac.

Regardless it still doesn't work either way. Also tried running disk utility first aid. No errors there.

There is no tmp-dir command in my configuration under advanced setting.s


User avatar
Posts: 2068
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue Jun 02, 2020 2:14 pm
Hi mjs,

Firstly, please make sure you're using the latest version of Viscosity (currently 1.8.5) and not an older version.

If you're seeing the same issue with the latest version, can you please post the following details. If you don't feel comfortable posting them on a public forum please feel free to email them to us using the details on our Support page.

1. A complete copy of the OpenVPN log for the connection:
https://www.sparklabs.com/support/kb/ar ... envpn-log/

2. The Raw Configuration Data for your connection. You can view the raw configuration data for your Viscosity connection by opening Viscosity’s Preferences window, holding down the Option/Alt key on your keyboard, right-clicking on your connection, and selecting “View Configuration Data”.

James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs


Posts: 3
Joined: Tue Jun 02, 2020 8:45 am

Post by mjs » Wed Jun 03, 2020 1:14 am
I am already running 1.8.5.

Configuration Data (sanitized)
#-- Configuration Generated By Viscosity --#
#viscosity startonopen false
#viscosity dhcp true
#viscosity protocol openvpn
#viscosity name xxx
#viscosity dnssupport true
remote xxxx.xxxx.xxxx 1194 udp
dev tun
pkcs12 pkcs.p12
remote-cert-tls server
tls-auth ta.key 1
lport 0
auth SHA1
resolv-retry infinite
verify-x509-name "C=xx, ST=xxx, L=xxx, O=xxx, emailAddress=[email protected], CN=xxx" subject
cipher AES-128-CBC
comp-lzo adaptive

2020-06-02 10:08:07: Viscosity Mac 1.8.5 (1537)
2020-06-02 10:08:07: Viscosity OpenVPN Engine Started
2020-06-02 10:08:07: Running on macOS 10.15.4
2020-06-02 10:08:07: ---------
2020-06-02 10:08:07: State changed to Connecting
2020-06-02 10:08:07: Checking reachability status of connection...
2020-06-02 10:08:07: Connection is reachable. Starting connection attempt.
2020-06-02 10:08:07: Options error: Temporary directory (--tmp-dir) fails with '/tmp': Permission denied (errno=13)
2020-06-02 10:08:07: Options error: Please correct these errors.
2020-06-02 10:08:07: The OpenVPN subsystem could not be started.
2020-06-02 10:08:07: State changed to Disconnected


Posts: 3
Joined: Tue Jun 02, 2020 8:45 am

Post by mjs » Wed Jun 03, 2020 6:23 am
I got it to work. After taking a closer look at the permissions on a couple of other macs, I found that they are actually not set the same as the one I'm having issues with.

/private/tmp should be set to:

drwxrwxrwt 5 root admin 160 Jun 2 14:55 /private/tmp

It was previously set to:

drwxr-xr-x 5 root admin 160 Jun 2 14:55 /private/tmp

How that got changed, I have no idea.
4 posts Page 1 of 1