WOL not working.

Got a problem with Viscosity or need help? Ask here!

DeeGee

Posts: 4
Joined: Sat Sep 14, 2019 7:14 pm

Post by DeeGee » Sun Sep 15, 2019 12:36 am
Hi. I'm after some advice and am wondering if you guys can assist.
I have Viscosity that I use for a VPN tunnel and it's when I'm on VPN that I can't get my WOL app, Remote Wake to work. I have it configured to wake a Mac on my network when not on the VPN and it works fine.

The modem/routing device is a Netgear D7800-AC2600 and this appears to work absolutely fine as once the Macs on my network are awake I can access resources without issue.
I have configured port forwarding for port 9 UDP, I have tried port triggering on port 9, I have even tried port 9 TCP , just know that I've covered everything on that score.

Do you guys have any ideas perhaps?

Thanks.

James

User avatar
Posts: 1925
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Sun Sep 15, 2019 1:20 pm
Hi DeeGee,

A WoL request is a special low-level network packet. It requires that you be on the same subnet (i.e. IP range), or a router connected to the subnet configured to re-forward it if you're not.

The easiest way to get it to work is to use a TAP/bridged connection instead of a TUN/routed one. I believe Netgear's OpenVPN server web interface lists a "TAP Mode Service" (near the bottom of the VPN Service section). Take note of the protocol (UDP or TCP) and port number it has listed for TAP. Then edit your connection in Viscosity, change the Device to "tap", and change the port number and protocol to match.

As for the forwarding approach, simply forwarding the port is unlikely to be enough: almost all routers are going to drop a broadcast packet like a WoL request by default. You'd have to find a way to allow forwarding of broadcast packets on the router.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

DeeGee

Posts: 4
Joined: Sat Sep 14, 2019 7:14 pm

Post by DeeGee » Mon Sep 16, 2019 10:31 pm
James, that's great. I'll give that a try when I'm home again at the weekend and report back.

Thank you.

Hi James, as I can get into the router over VPN, I've just done that and adjusted my settings to suit. I can already see that the IP range has changed to match what I am used to seeing.
I'll do some more experimenting.

DeeGee

Posts: 4
Joined: Sat Sep 14, 2019 7:14 pm

Post by DeeGee » Mon Sep 16, 2019 10:55 pm
Just to add. Yesterday, I bought a Raspberry Pi.
Whilst on my network and even over VPN I could remote into it and get that to send the WOL packet so that part was successful.
However, I couldn't get the Mac Screen Sharing to work despite turning off the firewall and any other applications that affect networking. I'd also opened up ports 5900 to 5900 on the Pi, and 5901 to 5900 for the Mac.

Don't suppose you've had experience with Screen sharing?

James

User avatar
Posts: 1925
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue Sep 17, 2019 11:55 am
Yesterday, I bought a Raspberry Pi.
Fun little units - you can run your own OpenVPN server on one (just port forward from your router to it) if you want more control over your OpenVPN setup. :)
I'd also opened up ports 5900 to 5900 on the Pi, and 5901 to 5900 for the Mac.
If you mean on their local firewalls, then that's fine. I would not recommend exposing them to the internet by port forwarding from your router though.
Don't suppose you've had experience with Screen sharing?
If your VPN server setup is correct, then when you're connected using Viscosity it should be similar to being at home: everything that you can do while on your home network should be possible while connected to the VPN. You shouldn't need to change any firewall or port forwarding rules on the router or VPN server.

You can try directly connecting via IP address: Type "Screen Sharing" into the Spotlight menu and open the Screen Sharing app that appears. Then type the IP address of your Mac into the "Connect To" field, and click the Connect button.

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

DeeGee

Posts: 4
Joined: Sat Sep 14, 2019 7:14 pm

Post by DeeGee » Sat Sep 21, 2019 3:06 am
Hi James, thanks for your input.

So.......I saw running the VPN on one was an option, just thought that the router might be the better way to go???

The only port forward on my router is 12794, ( I removed the 5900 on the router shortly after I did it). I'll try the 5900 on the Mac and Pi if I can see how to do it, (am assuming configuring the correct options in the Sharing pane of System prefs will do that).

As for the screen sharing, I couldn't get it to work on any Macs, (was fine on the Pi), so I'll have to look at this again.
6 posts Page 1 of 1