Private Network instead of Unidentified Network (Win 10)

Got a problem with Viscosity or need help? Ask here!

doffactory

Posts: 10
Joined: Wed Jul 19, 2017 7:33 pm

Post by doffactory » Sat Jan 12, 2019 3:29 am
Would it be please possible to provide a setting in Viscosity that would set the successfully established openvpn connection as Private Network in Windows 10? At the moment any vpn connection made by Viscosity is categorised in Windows 10 as "Unidentified Network" which triggers automatically the Public Network setting (see screenshot).

This has then an adverse effect for my Firewall where I need to open ports for Public Networks to make things work, which I am very hesitant to do, as I often access proper public networks as well.


Screenshot: https://imgur.com/bVrQ0Le

Eric

User avatar
Posts: 905
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Mon Jan 14, 2019 9:04 am
Hi doffactory,

I must confess I haven't looked into this for a while but I believe the following is still relevant:

viewtopic.php?f=9&t=1630&p=4684

Please give it a go and let us know how you get on.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

doffactory

Posts: 10
Joined: Wed Jul 19, 2017 7:33 pm

Post by doffactory » Wed Jan 16, 2019 3:00 am
Hi Eric,

I read this and I tried to set it in the TCPv4 settings of the viscosity VPN virtual card settings. However, I get the following error (screenshot): https://imgur.com/nYedwRd

Am I doing anything wrong?

Eric

User avatar
Posts: 905
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Jan 16, 2019 2:22 pm
Hi doffactory,

You need to edit your connection in Viscosity, not Windows, and then follow the instructions in the forum post I linked. There is a more step by step guide for adding a route here - https://sparklabs.com/support/kb/articl ... connection

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

doffactory

Posts: 10
Joined: Wed Jul 19, 2017 7:33 pm

Post by doffactory » Wed Jan 23, 2019 11:11 am
Thanks for the help, seems like working.

doffactory

Posts: 10
Joined: Wed Jul 19, 2017 7:33 pm

Post by doffactory » Tue Jul 30, 2019 6:18 pm
Hi, in the meantime, I think I found a solution where the virtual Network Device created by Viscosity can be set as Private network by default. It is achieved through a PowerShell command, maybe worth investigating how to implement this into the installer?

Anyway, the link:
Code: Select all
https://answers.microsoft.com/en-us/windows/forum/windows_10-files/homegroup-removed-how-to-get-network-sharing-work/01277332-2916-4a68-853a-116696b20743

Eric

User avatar
Posts: 905
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Jul 31, 2019 11:47 am
Hi doffactory,

Thanks for your feedback.

You are in a very small minority that would need a Private Network/Homegroup over a VPN so I'm afraid this isn't something we would introduce into Viscosity by default.

We may explore adding this as an option if we receive more requests for such a feature though.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

doffactory

Posts: 10
Joined: Wed Jul 19, 2017 7:33 pm

Post by doffactory » Wed Jul 31, 2019 7:04 pm
You are welcome.
8 posts Page 1 of 1