How to fix tls-remote in openvpn 2.4.4

Got a problem with Viscosity or need help? Ask here!

quangvublog

Posts: 1
Joined: Fri May 17, 2019 6:54 pm

Post by quangvublog » Fri May 17, 2019 6:59 pm
Hello everyone!

My laptop is updated and openvpn also upgrading from 2.3 to 2.4, then my openvpn can't use and it gets this error
Options error: Unrecognized option or missing or extra parameter(s) in DEV.ovpn:10: tls-remote (2.4.4)
I have change tls-remote into verify-x509-name but it's still wrong. Please tell me how to fix it. Thanks!
Quang Vũ Blog
Địa chỉ: 432 Nguyễn Thị Minh Khai, Phường 5, Quận 3, Hồ Chí Minh
Phone: +84 977 689 733

Eric

User avatar
Posts: 872
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Fri May 17, 2019 7:29 pm
Hi quangvublog,

It looks like you're using OpenVPN-GUI rather than Viscosity. I recommend you ask this question on the OpenVPN forums for help on how to update your configuration.

In Viscosity, you can edit your connection, go to the Advanced tab and make the change you have mentioned there to resolve this error.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1