Viscosity v1.7.14 not able to find .NET in Windows 10 Enterprise Edition

Got a problem with Viscosity or need help? Ask here!

mrgswift

Posts: 2
Joined: Sat Apr 20, 2019 1:49 am

Post by mrgswift » Tue Apr 23, 2019 3:31 am
Hello,

I am having issues with the latest version of Viscosity (1.7.14). Viscosity has been working great up until this latest version. The older version I had installed works but after the updating to the latest version it stopped working. I tested this by uninstalling the latest version and installing an older version (1.7.6) and it started up without any problems. Only version 1.7.14 seems to have problems. I have attached screenshots. I know for a fact .NET is installed because the old version works and because Windows 10 with the latest updates (which are installed) require the .NET framework as an OS component.

Not being able to run the updated version will present problems for me, as I need to have the latest security updates. If this can't be resolved, I may need to move on to other VPN client solutions.

Your help is greatly appreciated.
Attachments
vicosity-1.7.14-program-files-directory-version.png
screenshot of program files directory v1.7.14
vicosity-1.7.14-program-files-directory-version.png (71.05 KiB) Viewed 387 times

vicosity-1.7.14-not-starting-screenshot.png
Attempt to open Viscosity v1.7.14 (can't find .NET)
vicosity-1.7.14-not-starting-screenshot.png (109.42 KiB) Viewed 387 times

vicosity-1.7.6-screenshot.png
Working in v1.7.6
vicosity-1.7.6-screenshot.png (188.62 KiB) Viewed 387 times

Eric

User avatar
Posts: 871
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Apr 23, 2019 10:10 am
Hi mrgswift,

Viscosity 1.7.13+ now requires .NET 4.6.2 or later, it would appear you only have .NET 4.5.2 installed, this is what older version of Viscosity required. I'm afraid we accidentally overlooked automatically installing the required .NET version in this installer, this will be fixed from Viscosity 1.7.15 onwards.

You can manually download and install .NET 4.6.2 by clicking Yes to the dialog in your screenshot, or downloading the installer here - https://www.microsoft.com/en-au/download/details.aspx?id=53344

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

mrgswift

Posts: 2
Joined: Sat Apr 20, 2019 1:49 am

Post by mrgswift » Wed Apr 24, 2019 2:50 am
Hi Eric,

Thanks for the reply. I was actually running .NET 4.6.0. I went to the link you posted and .NET v4.6.2 installed without any problems, finally allowing me to run Viscosity 1.7.14.

Just FYI, when I click Yes on the dialog to install .NET 4.6.2, it takes me to the .NET v4.7.2 download page. When I download the installer and run it, the setup program gives me the message Blocking Issues: ".NET Framework 4.7.2 is not supported on this operating system" (screenshots attached). Setup would then not continue and force me to close it.

However, when I clicked the installer link you gave me and download, the setup program ran fine and installed .NET 4.6.2. After looking at everything, I noticed the link you gave me sends me directly to the download page specifically for .NET v4.6.2, but the dialog to download .NET initiated by Viscosity seems to be sending me to the .NET download page with the latest version of .NET. It would appear the latest version is not compatible out of box with some installations of WIndows 10. You may want to correct this somehow, as this was the source of my frustration, and it may not be obvious to some users why it doesn't work when they click Yes in the dialog to download.

Thanks again for your help!
Attachments
viscosity_yes_clicked_NET_website.png
.NET v4.7.2 download page after clicking Yes in the dialog
viscosity_yes_clicked_NET_website.png (125.4 KiB) Viewed 377 times

viscosity_NET_website_download.png
Download of .NET v4.7.2
viscosity_NET_website_download.png (242.66 KiB) Viewed 377 times

viscosity .NET blocking issue.png
Error/Blocking Issue preventing install of .NET
viscosity .NET blocking issue.png (14.66 KiB) Viewed 377 times

Eric

User avatar
Posts: 871
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Apr 24, 2019 10:39 am
Hi mrgswift,
Wed Apr 24, 2019 2:50 ammrgswift wrote:
After looking at everything, I noticed the link you gave me sends me directly to the download page specifically for .NET v4.6.2, but the dialog to download .NET initiated by Viscosity seems to be sending me to the .NET download page with the latest version of .NET. It would appear the latest version is not compatible out of box with some installations of WIndows 10. You may want to correct this somehow, as this was the source of my frustration, and it may not be obvious to some users why it doesn't work when they click Yes in the dialog to download.
I'm afraid this dialog is generated by Windows, not Viscosity, so we don't have control over this. Very strange that you can't install .NET 4.7.2 on Windows 10 though.

The Viscosity installer will install .NET 4.6.2 before future users see this dialog from the next release.

Glad to hear it's working.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
4 posts Page 1 of 1