Page 1 of 1

Private Network instead of Unidentified Network (Win 10)

Posted: Sat Jan 12, 2019 3:29 am
by doffactory
Would it be please possible to provide a setting in Viscosity that would set the successfully established openvpn connection as Private Network in Windows 10? At the moment any vpn connection made by Viscosity is categorised in Windows 10 as "Unidentified Network" which triggers automatically the Public Network setting (see screenshot).

This has then an adverse effect for my Firewall where I need to open ports for Public Networks to make things work, which I am very hesitant to do, as I often access proper public networks as well.


Screenshot: https://imgur.com/bVrQ0Le

Re: Private Network instead of Unidentified Network (Win 10)

Posted: Mon Jan 14, 2019 9:04 am
by Eric
Hi doffactory,

I must confess I haven't looked into this for a while but I believe the following is still relevant:

viewtopic.php?f=9&t=1630&p=4684

Please give it a go and let us know how you get on.

Regards,
Eric

Re: Private Network instead of Unidentified Network (Win 10)

Posted: Wed Jan 16, 2019 3:00 am
by doffactory
Hi Eric,

I read this and I tried to set it in the TCPv4 settings of the viscosity VPN virtual card settings. However, I get the following error (screenshot): https://imgur.com/nYedwRd

Am I doing anything wrong?

Re: Private Network instead of Unidentified Network (Win 10)

Posted: Wed Jan 16, 2019 2:22 pm
by Eric
Hi doffactory,

You need to edit your connection in Viscosity, not Windows, and then follow the instructions in the forum post I linked. There is a more step by step guide for adding a route here - https://sparklabs.com/support/kb/articl ... connection

Regards,
Eric

Re: Private Network instead of Unidentified Network (Win 10)

Posted: Wed Jan 23, 2019 11:11 am
by doffactory
Thanks for the help, seems like working.