SparkLabs Forum.

Community Help.

torrent clients keep viscosity in "disconncting" state

So, here is the problem.
Viscosity connects, runs connection script to open torrent client.
when promted to disconnect it goes into disconnected state, and never runs the disconnect script to kill processes. so while in that state VPN IS disconnected but viscosity stays in "disconnecting" state and never kills the process.

as you see from log i gave it 6minutes but only goes in to "disconnected" after i manually kills torrent client.
nov 15 22:13:52: State changed to Connected
nov 15 22:14:02: State changed to Disconnecting
nov 15 22:20:00: State changed to Disconnected

2nd part of this problem is, when this happens i usually loose internet connection up to 99% so i get "page cannot be shown" "no connection to internet" and so on in anything that uses internet, but VPN keeps connected during this.
Also when i kill torrent client, the connection popps back and all is "normal"

I have tried diffrent torrent clients, Same issue, so might it be a protocol issue?

Why do viscosity stay in Disconnecting state and never fully disconnect?

Any ideas?
Hi frodrick,

If you double click the script you are using does it successfully kill your process? Please ensure you are not testing the script as Administrator, as Viscosity runs as a standard user. It sounds like the script is getting stuck.

Script works fine, no admin rights needed.
Problem is it just wont run it.
Is there any debug options to see what viscosity is waiting for?

Also this morning i noticed viscosity indicating that it was connected and green icon was showing. Log said connected
BUT it was not connected at all, networkadapter was blue with red cross indicating "cable not connected" bit it was active.
So torrent client was active and i tried to disconnect but same "disconnecting" state happened and i had to manually run script to kill torent. And after that it changed to "disconnected"
Hi frodrick,

Could you please send us a complete copy of your script, configuration (Hold Shift, right click your connection in Viscosity and select View configuration data), and a complete copy of your log so we can try to replicate the issue you are facing. You may wish to email this to us instead as this forum is public ([email protected]). It sounds like the script is waiting for user input and getting stuck. I assume you have no problems disconnecting if you remove the script from your configuration?

I might have tried that but cant remember outcome, guessing it was the same. Cause it only changes to discobnected state after a manually run script OR shut torrent client off.

So i cant try anything until i get of work in 11hours.
5 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy