Viscosity service has very high cpu load

Got a problem with Viscosity or need help? Ask here!

Gali

Posts: 1
Joined: Wed Oct 17, 2018 6:10 pm

Post by Gali » Wed Oct 17, 2018 8:17 pm
Hello there,

I am very happy with viscosity. But recently I had recurring problems with the viscosity background service.

Every few days, the service uses more and more cpu, up to the point where the system is nearly non-responsive.
I can kill the process und restart viscosity and all connections, but this in very inconventient.

The system is running thoughout the work-week and I keep 1-2 connections open to my servers. But this should be no problem per se, and I did this without problems with other vpn clients.

I could not find anything like that in your support pages or with google.

Is there anything I can do? Is this an known issue?

Thanks.

Eric

User avatar
Posts: 883
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Thu Oct 18, 2018 11:26 am
Hi Gali,

There is no known issue like this, very strange. Are you able to let us know the version of Viscosity, .NET and Windows you are using? These are both printed out in the log when you first connect for an easy place to find them.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

zmitja

Posts: 2
Joined: Tue Nov 20, 2018 8:35 pm

Post by zmitja » Tue Nov 20, 2018 8:52 pm
Hi,

I have the same problem. It is occurring since the last Windows 10 updates a few weeks ago.
Viscosity service produces high CPU load when connected, otherwise it sleeps.
My Windows version: Windows 10 Pro, build 17134
Viscosity: 1.7.12 (1581)
.NET Framework 4.7.2

Regards,
Mitja

Eric

User avatar
Posts: 883
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Nov 21, 2018 10:14 am
Hi Mitja,

As a test, do you see the same high CPU load if you change your DNS mode to Disabled? To do this, edit your connection, go to Networking and change the DNS Mode to Disabled, save your connection and then connect again.

Wait a minute or two and see if the CPU usage still spikes, then you will probably want to change this back to what it was.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

zmitja

Posts: 2
Joined: Tue Nov 20, 2018 8:35 pm

Post by zmitja » Thu Nov 22, 2018 10:11 pm
Hi,

this workaround indeed solved the problem.
With "DNS mode" set to disabled, CPU does not spike neither due to traffic over VPN connection, nor
due to other network traffic.

Thank you and regards,
Mitja

Eric

User avatar
Posts: 883
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Fri Nov 23, 2018 7:41 am
Hi zmitja,

Please familiarise yourself with the DNS modes to ensure you are happy to continue to use Disabled - https://sparklabs.com/support/kb/articl ... #dns-modes

It sounds like you must have an extreme amount of DNS traffic, I recommend scanning for viruses or malware. If the problem persists, please let us know and we'll get some debug data from you to see if we can help you diagnose it.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
6 posts Page 1 of 1