Viscosity not reconnecting on disconnect

Got a problem with Viscosity or need help? Ask here!

Zaeed

Posts: 3
Joined: Mon Mar 12, 2018 7:50 pm

Post by Zaeed » Mon Mar 12, 2018 7:52 pm
Hey all,

Recently i've noticed my VPN will disconnect but Viscosity does not seem to reconnect, despite the option being selected. Is this a known issue or is there a fix?

Cheers

Eric

User avatar
Posts: 861
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Mar 13, 2018 11:20 am
Hi Zaeed,

This is a known issue and we are still working on a fix unfortunately.

In the mean time, to work around this, edit your connect, go to the Advanced tab and on a new line add the following:

remap-usr1 SIGTERM

Save your connection and reconnect. This will cause OpenVPN to terminate in the case of a drop out which Viscosity will correctly detect and then reconnect.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

Zaeed

Posts: 3
Joined: Mon Mar 12, 2018 7:50 pm

Post by Zaeed » Sat Mar 17, 2018 2:42 pm
Cheers!

Zaeed

Posts: 3
Joined: Mon Mar 12, 2018 7:50 pm

Post by Zaeed » Wed Mar 21, 2018 12:33 pm
Hey,

Just found it had disconnected again, even with that code added in.

Looking at the logs I see this:
Mar 17 21:34:07: FRAG TTL expired i=17
Mar 18 14:19:12: FRAG TTL expired i=2
Mar 18 14:19:12: FRAG TTL expired i=4
Mar 21 00:16:02: [Server-3089-3a] Inactivity timeout (--ping-restart), restarting
Mar 21 00:16:02: SIGTERM[soft,ping-restart] received, process exiting
Mar 21 00:16:02: State changed to Disconnected

Any thoughts as to what is going on?

Eric

User avatar
Posts: 861
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Mar 21, 2018 12:39 pm
Hi Zaeed,

We believe we have resolved the bug in the latest beta, please give it a go, you can remove the remap-usr1 command using it - http://sparklabs.com/support/kb/article ... -versions/

If you would like to address the dropouts, please see the following - http://sparklabs.com/support/kb/article ... g-restart/

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

doffactory

Posts: 7
Joined: Wed Jul 19, 2017 7:33 pm

Post by doffactory » Fri Mar 23, 2018 3:06 pm
Hi, I am having the same issue running the beta7.

Eric

User avatar
Posts: 861
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Fri Mar 23, 2018 4:00 pm
Hi doffactory,

Could you please post a complete copy of your log - https://sparklabs.com/support/kb/articl ... envpn-log/

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
7 posts Page 1 of 1