SparkLabs Forum.

Community Help.

Slow to connect to server

Viscosity seems slow to connect to the server.

My reading the log it goes from "Connecting, first start" to "Initialization Sequence Completed" in 4 seconds, the is quite fair.

But then is seems to do nothing for 13 seconds, before it set DNS and is connected.

feb 26 23:15:18: Initialization Sequence Completed
feb 26 23:15:31: DNS set to Full:
Server - xxxxxx; Lookup Type - Any; Domains - xxxxx., xxxxx.
feb 26 23:15:31: Tilstand ændret til Connected.

I have tested with the same server/setting under Ubuntu, and it connects in 2 seconds from start to full connected.
Hi shade1973,

Viscosity does a lot of extra setup in this time to prevent DNS leaks, depending on your PC and environment this can unfortunately take some time, especially if Viscosity is coexisting with firewalls and AV software, as it's sadly a case of lining up while everything has their bite at your PC's resources after the change in network. A modern (less than 5 years old) PC that is not fighting for resources should only take a second to complete this step.

We made some improvements specifically for WiFI connections in our last beta, you may wish to give this is a try to see if it improves your connection time - ... -versions/

Other steps you can take to improve this is ensure all Windows Updates are installed, .NET is up to date, and cutting down on software that is open at the same time that isn't required to be open.

Also, is there a place to see all the available #viscosity commands for the connection config file?

Mine is made years ago, and mabee it have deprecated #viscosity commands, that slows it down?
Hi shade1973,

We don't have a list anywhere, but there are no #viscosity commands that would slow down your connection time.

The newest beta seems to shave 1-2 seconds of the total connection time.

I am on wifi and on a Lenovo T460 with a iCore5-6300 CPU, CPU load seems low under the connection.

Computer is full updated with all updates from Microsoft.
My conection config, have these #viscosity commands:

#viscosity name xxxx
#viscosity ipv6 false
#viscosity dns automatic
#viscosity usepeerdns true
#viscosity manageadapter false
#viscosity startonopen false
#viscosity autoreconnect false

If I generate a new config from our OpenVPN server (OPNsense) it creates a new config with theese commands:

#viscosity startonopen false
#viscosity dhcp true
#viscosity name xxxx
#viscosity dns automatic

Does that change much?
6 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy