How NOT TO "Preserve recently used address"?

Got a problem with Viscosity or need help? Ask here!

markusj

Posts: 6
Joined: Wed May 21, 2014 3:56 am

Post by markusj » Tue Jan 30, 2018 5:01 am
Hi! Im getting really sick of this thing. No help anywhere. No, not in openVPN guides either. :oops:

The problem is, that Viscosity reports that "Preserving recently used remote address" and uses the same IP-address (I have putted it to connect to IP:s, not DNS-names) where it connects EVERY TIME, even thought there are dozen or so other IP-addresses available where it could connect to! I have putted the "remote-random" command into "Extra VPN-commands" but apparently Viscosity STILL uses the recently used remote address to connect every time I connect or reconnet the VPN-connection.

How can I permanently PREVENT THIS and have the Viscosity EVERY TIME connect to totally random IP/Address from the pool of addresses I have given it? :evil:

Eric

User avatar
Posts: 861
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Tue Jan 30, 2018 9:59 am
Hi markusj,

The "Preserving recently used remote" can be ignored, this message is displayed regardless of it's use and is only reused in the event of a drop out/reconnect. If you disconnect and then reconnect, the preserved address is not reused.

First, go to General and ensure you have multiple Remote Server Addresses entered, the remote-random command will not span multiple connections, multiple addresses must be in one connection.

Next, go to Options and ensure Persist Tun, Persist Local IP and Persist Remote IP are all unchecked.

Finally, assuming you have entered remote-random on a new line in Advanced, each time you connect Viscosity should use a random address from the list for this connection.

If you are still having problems after all this, could you please email us a copy of your connection configuration and log and we can take a look.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

markusj

Posts: 6
Joined: Wed May 21, 2014 3:56 am

Post by markusj » Fri Feb 02, 2018 7:57 am
Thanks for your reply.

> The "Preserving recently used remote" can be ignored, this message is displayed
> regardless of it's use and is only reused in the event of a drop out/reconnect. If you
> disconnect and then reconnect, the preserved address is not reused.

The funny thing is that this was NOT correct before, my Viscosity did use the old address still and never connect to other server. I logged the IP:s and checked many times in a row. Even rebooting the system didnt solve this problem. It always sayed it connected to previously used address and it always did so! It never connected to any other address, even they where available.

HOWEVER, now it doesnt! I dont understand this. Now I logged the IP:s again many times and it always connects to different IP. I dont understand how this is now happening like this, but apparently the problem is now solved! :mrgreen:
3 posts Page 1 of 1