SparkLabs Forum.

Community Help.


Windows DNS settings not reverting

Hi,

We have several Viscosity Windows users and some of them encounter DNS problems quite often.

Our setup is pretty simple, we push our internal corporate DNS servers to clients and we use the Full DNS mode. On connection Viscosity modify the network adapter DNS settings from DHCP assigned (Obtain DNS server address automatically) to static (Use the following DNS server addresses). From what I understand, since version 1.6, it is the normal behaviour. It is also good to note that when the user disconnect the settings are reverted from static to DHCP, which is the way it should always be.

However, quite often, our helpdesk team receive calls from people that can't use their laptop anymore. After investigation we found that they were not connected to the VPN anymore but the DNS settings were still statically assigned to our Internal DNS servers. Since those servers are not available outside the company, they can't query them, which leave them with an unusable laptop.

I did some testing and was able to reproduce the problem if I kill the Viscosity and OpenVPN processes, which makes me think that when people encounter the problem, it is because Viscosity crashed and wasn't able to revert the settings.

I would like to know if someone have seen this, and if so, what is the fix to avoid this situation?

Thanks,
Jean-Philippe
Hi Jean-Philippe,

First, please ensure your users are using the latest version of Viscosity. Each version has added further failsafes to prevent stuck DNS. If you kill the Service and OpenVPN, and then restart the service, DNS should revert under normal conditions. The same stands if the computer crashes or bluescreens, DNS should be reverted at restart.

Currently we are aware of an issue where some AV software is monitoring the failsafe DNS settings and preventing these being written. If this is happening, you should see errors reported to Event Viewer. If so, whitelist the file that is failing to be written as reported in the event viewer and this should alleviate the problem.

Regards,
Eric
2 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy