SparkLabs Forum.

Community Help.


Windows 10 - viscosity services stops at random

Hi

I've been struggeling with a strange issue for my VPN connection, the connection works for 95% of the time, I can connect without issues and the connection will work for anything between 1hour to 100 hours, but at random times my "Viscosity Service" ("C:\Program Files\Viscosity\ViscosityService.exe") stops.

When this happends it looks like im still connected to the VPN service, but DNS is not working, any lookups i do fails.

- Tried the newest version and 3 older ones
- Tried reinstallting my windows 10 machine
- Tried using windows server 2016
- Disabled Windows Defender
- Disabled Windows Firewall
- No other software firewall/antivirus is running
- Tried setting the windows service to restart the service at first failure, second failure and subsequent failure.

If i manualy start the service from the window service management console my DNS works again for a random period of time untill next stop.

I've tried googeling and searching your forums for similar problems but pretty much all similar problems seems to be when people connects to the VPN service, and this works fine fore me.

My machine is running on VMware esxi 5.5, using E100E adapter for the network card, no specific network setup for the host, just a regular standard switch which comes with the installation of vmware esxi.


Any idéa what I could try to find out the possible cause?
Hi martikainen,

As a first step, please check the Event Viewer for errors from ViscosityService, or other errors or warnings around the time when the service is stopping - http://sparklabs.com/support/kb/article ... nt-viewer/

Regards,
Eric
I have a few events, maybe this can help you find out what the issue is

Under systems

2017-10-08 10:40:33
Source: Service Control manager
Event ID: 7034
General: The Viscosity Service service terminated unexpectedly. It has done this 1 time(s).

And after that i get warnings on the DNS Client Events that name resolutions are timing out.

In Application

2017-10-08 10:40:31

Source: Application Error
Event ID: 1000
General: Faulting application name: ViscosityService.exe, version: 1.7.3.1521, time stamp: 0x59533d14
Faulting module name: clr.dll, version: 4.7.2110.0, time stamp: 0x597bd642
Exception code: 0xc00000fd
Fault offset: 0x000000000019588a
Faulting process id: 0x1170
Faulting application start time: 0x01d3400367cd2f3c
Faulting application path: C:\Program Files\Viscosity\ViscosityService.exe
Faulting module path: C:\Windows\Microsoft.NET\Framework64\v4.0.30319\clr.dll
Report Id: 6c256775-08fd-4cc3-b71b-beb5da48e1bf
Faulting package full name:
Faulting package-relative application ID:


And the logs from the viscosity client:

okt 04 08:32:49: State changed to Connected
okt 08 10:38:31: write UDP: No buffer space available (WSAENOBUFS) (code=10055)
okt 08 10:38:32: Disconnecting connection as it is no longer reachable
okt 08 10:38:32: State changed to Disconnecting
okt 08 10:38:32: SIGTERM received, sending exit notification to peer
okt 08 10:38:33: Warning: route gateway is not reachable on any active network adapters: 192.168.1.1
okt 08 10:38:33: env_block: add PATH=C:\Windows\System32;C:\Windows;C:\Windows\System32\Wbem
okt 08 10:38:33: SIGTERM[hard,] received, process exiting
okt 08 10:38:33: State changed to Disconnected
okt 08 10:39:45: State changed to Connecting
okt 08 10:39:45: Viscosity Windows 1.7.3 (1521)
okt 08 10:39:45: Running on Microsoft Windows 10 Enterprise
okt 08 10:39:45: Bringing up interface...
okt 08 10:39:45: Checking reachability status of connection...
okt 08 10:39:46: Connection is reachable. Starting connection attempt.
okt 08 10:39:46: WARNING: The block-outside-dns option has been ignored as it is not required under Viscosity's DNS management system. For more information please see the following article: https://www.sparklabs.com/support/kb/ar ... n-ignored/
okt 08 10:39:46: OpenVPN 2.4.3 Windows-MSVC [SSL (OpenSSL)] [LZO] [LZ4] [PKCS11] [AEAD] built on Jun 21 2017
okt 08 10:39:46: library versions: OpenSSL 1.0.2l 25 May 2017, LZO 2.09
okt 08 10:39:47: NOTE: the current --script-security setting may allow this configuration to call user-defined scripts
okt 08 10:39:47: TCP/UDP: Preserving recently used remote address: [AF_INET]46.227.67.147:1196
okt 08 10:39:47: UDP link local: (not bound)
okt 08 10:39:47: UDP link remote: [AF_INET]46.227.67.147:1196
okt 08 10:39:47: State changed to Authenticating
okt 08 10:39:47: WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
okt 08 10:39:47: [ovpn.se] Peer Connection Initiated with [AF_INET]46.227.67.147:1196
okt 08 10:39:49: State changed to Connecting
okt 08 10:39:49: Option 'explicit-exit-notify' in [PUSH-OPTIONS]:6 is ignored by previous <connection> blocks
okt 08 10:39:49: open_tun
okt 08 10:39:49: TAP-WIN32 device [ovpn-se-stockholm-ipv4] opened: \\.\Global\{60980E59-6807-4341-844E-D3C5C6EABF59}.tap
okt 08 10:39:49: Set TAP-Windows TUN subnet mode network/local/netmask = 185.147.237.0/185.147.237.141/255.255.255.0 [SUCCEEDED]
okt 08 10:39:49: Notified TAP-Windows driver to set a DHCP IP/netmask of 185.147.237.141/255.255.255.0 on interface {60980E59-6807-4341-844E-D3C5C6EABF59} [DHCP-serv: 185.147.237.254, lease-time: 31536000]
okt 08 10:39:49: Successful ARP Flush on interface [8] {60980E59-6807-4341-844E-D3C5C6EABF59}
okt 08 10:39:49: do_ifconfig, tt->did_ifconfig_ipv6_setup=0
okt 08 10:39:54: Initialization Sequence Completed
okt 08 10:39:54: DNS set to Full:
Server - 46.227.67.134:53; Lookup Type - Any; Domains - None
Server - 192.165.9.158:53; Lookup Type - Any; Domains - None
Hi martikainen,

There should be more information in that event under Application, or another Error event logged that will give us more information. If you could post that it should point us to what is going on. Preferably, could you please post all events around that time.

Regards,
Eric
Ah there was some "information" events.

Application logs:

2017-10-08 10:40:33
Source: Windows Error Reporting
Event ID: 1001
General: Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: ViscosityService.exe
P2: 1.7.3.1521
P3: 59533d14
P4: clr.dll
P5: 4.7.2110.0
P6: 597bd642
P7: c00000fd
P8: 000000000019588a
P9:
P10:

Attached files:

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_ViscosityService_c0ee68d0fb362a6457b6b78c9ed7663ccb885dda_16d750b7_50d850ea

Analysis symbol:
Rechecking for solution: 0
Report Id: 6c256775-08fd-4cc3-b71b-beb5da48e1bf
Report Status: 4
Hashed bucket:

And after this event a bunch of information events regarding WindowsUpdateFailure3 and StoreAgentScanForUpdatesfailure0 which i assume is depending on a connection to the WAN.

also found these events in the System logs prior to the crash

2017-10-08 10:38:31
Level: Warning
Source: e1iexpress
Event ID: 27
General: Intel(R) 82574L Gigabit Network Connection
Network link is disconnected.


and

2017-10-08 10:38:33
Level: Information
Source: BROWSER
Event ID: 8033
General: The browser has forced an election on network \Device\NetBT_Tcpip_{60980E59-6807-4341-844E-D3C5C6EABF59} because a master browser was stopped.

2017-10-08 10:38:33
Level: Warning
Source: Mup
Event ID: 139
General: {Delayed Write Failed} Windows was unable to save all the data for the file \\192.168.1.20\nas\XXXX; the data has been lost. This error may be caused by network connectivity issues. Please try to save this file elsewhere.

2016-10-08 10:38:33
Level: Information
Source: Application Popup
Event ID: 26
General: Application popup: Windows - Delayed Write Failed : Exception Processing Message 0xc000a080 Parameters 0x7ffaa1b11d28 0x7ffaa1b11d28 0x7ffaa1b11d28 0x7ffaa1b11d28

Googled a few times on these errors, did a SFC check on both the server with VPN on and also my NAS. No errors found
Checked the Event Viewer of my NAS at the period for the errors on the server with VPN. (And it also seems illogical that the VPN service would stop if it can't connect to my NAS. )
Hi martikainen,

Thanks for posting up that extra information but unfortunately it doesn't help. Are there two errors posted for ViscosityService or just one? There should be a second error with different information in it, this is what we need to diagnose the problem.

Regards,
Eric
Only one as far as i can tell

[img][img]https://preview.ibb.co/eFJoqb/Capture.png[/img][/img]

The marked "informatio" error is the event "Event name: APPCRASH" i posted earlier

the first error below it is the event "Faulting application name: ViscosityService.exe, version: 1.7.3.1521, time stamp: 0x59533d14" i posted earlier

The second error below that is a license error in windows (License Activation (slui.exe) failed with the following error code:)

And in the system logs i only have 1 warning (License Activation (slui.exe) failed with the following error code:)

I can't find any other events with level "Error" that has anything related to viscosity

Can i dump the logs and send them to you somehow, if you have that kind of support?
one thing i do notice is that this information event is reoccuring sometimes every other hour, sometimes 2-3 hours between.

Checking the link described in the event gives me noting, the folder is empty.

Code: Select all

Fault bucket , type 0
Event Name: APPCRASH
Response: Not available
Cab Id: 0

Problem signature:
P1: ViscosityService.exe
P2: 1.7.3.1521
P3: 59533d14
P4: clr.dll
P5: 4.7.2110.0
P6: 597bd642
P7: c00000fd
P8: 000000000019588a
P9:
P10:

Attached files:

These files may be available here:
C:\ProgramData\Microsoft\Windows\WER\ReportQueue\AppCrash_ViscosityService_c0ee68d0fb362a6457b6b78c9ed7663ccb885dda_16d750b7_50d850ea

Analysis symbol:
Rechecking for solution: 0
Report Id: 6c256775-08fd-4cc3-b71b-beb5da48e1bf
Report Status: 96
Hashed bucket:
Hi martikainen,

It would seem something is terminating/interfering with Viscosity rather than it crashing on it's own. At this point we can't even speculate what is happening as we don't have much information to go on. With the dump folder also being empty as you mentioned, I'd be more inclined to believe there is a problem with the operating system install.

All we can really recommend is trial and error. Run up a fresh VM, install Viscosity and ensure it's working on it's own, then start adding other applications or activities you run on the VM one by one and see if the crashes start occurring again.

Regards,
Eric
Alright, the issues is that this was a new VM with a different operating system. The only thing in common is the network adapter on the VM (type of adapter) and the VPN profile, I'll contact my VPN provider to see if they have any tips, might be related to a high amount of UDP connections or smiliar.

Thanks for all the help so far! I'll update the thread if I find a solution!
9 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy