SparkLabs Forum.

Community Help.


Viscosity Shows Connected but I can't see our server

Im trying to connect my home pc (windows 10 pro) to our work server using viscosity. Other colleagues have done the same with success. I imported the settings from one colleague who is able to connect to our server using viscosity. I can get viscosity to connect, but when i look in File Explorer/Network i don't see the server. If i try typing \\QNAPNAS in the address bar at the top of Network it says:

\\qnapnas is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have the access permissions.

A specified logon session does not exist. It may already have been terminated.


Here is the connection log:

Apr 10 11:56:28 AM: State changed to Connecting
Apr 10 11:56:28 AM: Viscosity Windows 1.6.8 (1477)
Apr 10 11:56:28 AM: Running on Microsoft Windows 10 Pro
Apr 10 11:56:28 AM: Bringing up interface...
Apr 10 11:56:28 AM: Checking reachability status of connection...
Apr 10 11:56:28 AM: Connection is reachable. Starting connection attempt.
Apr 10 11:56:29 AM: OpenVPN 2.3.14 Windows-MSVC [SSL (OpenSSL)] [LZO] [PKCS11] [IPv6] built on Jan 16 2017
Apr 10 11:56:29 AM: library versions: OpenSSL 1.0.2j 26 Sep 2016, LZO 2.09
Apr 10 11:56:29 AM: WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
Apr 10 11:56:29 AM: Deprecated TLS cipher name 'SRP-RSA-3DES-EDE-CBC-SHA', please use IANA name 'TLS-SRP-SHA-RSA-WITH-3DES-EDE-CBC-SHA'
Apr 10 11:56:29 AM: Deprecated TLS cipher name 'DHE-RSA-AES128-SHA', please use IANA name 'TLS-DHE-RSA-WITH-AES-128-CBC-SHA'
Apr 10 11:56:29 AM: Deprecated TLS cipher name 'DHE-RSA-AES256-SHA', please use IANA name 'TLS-DHE-RSA-WITH-AES-256-CBC-SHA'
Apr 10 11:56:29 AM: UDPv4 link local: [undef]
Apr 10 11:56:29 AM: UDPv4 link remote: [AF_INET]12.37.170.194:1194
Apr 10 11:56:29 AM: WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Apr 10 11:56:30 AM: [TS Series NAS] Peer Connection Initiated with [AF_INET]12.37.170.194:1194
Apr 10 11:56:32 AM: do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Apr 10 11:56:32 AM: open_tun, tt->ipv6=0
Apr 10 11:56:32 AM: TAP-WIN32 device [openvpn1] opened: \\.\Global\{47A4E3AC-6827-41B9-9FC5-8204F5729EE2}.tap
Apr 10 11:56:32 AM: Notified TAP-Windows driver to set a DHCP IP/netmask of 10.8.0.10/255.255.255.252 on interface {47A4E3AC-6827-41B9-9FC5-8204F5729EE2} [DHCP-serv: 10.8.0.9, lease-time: 31536000]
Apr 10 11:56:32 AM: Successful ARP Flush on interface [16] {47A4E3AC-6827-41B9-9FC5-8204F5729EE2}
Apr 10 11:56:37 AM: Initialization Sequence Completed
Apr 10 11:56:40 AM: DNS set to Full.
Apr 10 11:56:40 AM: State changed to Connected


It seems as though something on my home pc is causing the issue as others have done the same procedure and it works. I don't have any experience with vpn's really, so the solution could be simple. Thanks.
Hi CotneyAero,

Without knowing your VPN configuration, we highly recommend you contact your VPN Provider (i.e. your workplace IT) for assistance with this. It is most likely a DNS or routing configuration issue. It would be worth trying to access the server by its IP address as well if you know it.

Regards,
Eric
Hey CotneyAero,

I second Eric's post bang on in that it sounds like dns or routing. But it could also be a firewall on the QNAP, as you can configure the QNAP to accept/reject connections based on the originating IP/subnet. (but I doubt it given a co-worker can access it)

Definitely trying to access the QNAP via IP is the right first step, if that works its almost guaranteed to be DNS related. If you can reach it by IP you should then try using the FQDN not just the hostname eg. \\QNAPNAS.localdomain (where localdomain is the internal domain)

If your not sure about what the domain is or if one exists, again your IT department can help with that.

Hopefully these tips help you find your QNAP :)
-Zenon
3 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy