SparkLabs Forum.

Community Help.


Not connecting on Windows Embedded Standard SP3 on HP TC

Hi
Just tried on my laptop with Win7 with latest version of Viscosity vpn client, worked awesome. However, when tried on my thin client ( Windows Embedded Standard SP3) with legacy version ie v1.5 of viscosity it behaved in following way-
1. Installation was normal, means it didn't ask for Continue anyway....
2. Imported two client and got the message of successful import for both.
3. Right clicked the icon on the tray to connect each client one by one, it didn't connect.
4. Opened the preferences and tried to connect, it displayed 'creating' for about 1 min. and lastly displayed 'Disconnected' with a message popped up on the tray that 'A network cable is unplugged'.
5. No. of network adapters keeps on increasing from 2 to 12 and still increasing.
6. Checked the device manager, found many network adapters such as Viscosity Virtual Adapter V9.1, V9.1#2, #3 and so on, all enabled.
Please help me to have successful connection through viscosity openvpn client.

Lots of thanks in advance.
Hi ssaahw,

Viscosity was never designed to work in an Embedded Thin Client environment, especially one as old as Embedded XP. We also no longer support the Windows XP family. I have my doubts our drivers will even work in an Embedded OS.

Can you please uninstall Viscosity and reboot the server. After this, reinstall Viscosity, import one connection and try to connect.

If this fails, please go to Device Manager and check on the Status of the adapter(s) that are being installed. Are there any errors displayed in the Device Status while the adapter is enabled?

Regards,
Eric
Hi
Lots of thanks in advance as I believe I would definitely get guidelines from you.
I am now starting with a fresh thin client with windows embedded standard sp3 (similar to windows XP)
* I installed Viscosity setup for xp downloaded from 'Legacy downloads for older operating systems'.
* Opened event viewer and device manager side by side.
* Filtered for viscosity service and service1, there is no event for the first while there is an information for the later- 'Service started successfully'
* At the moment when I just installed the setup there is no other network adapter other than built in Broadcom NetLink Gigabit Ethernet #3.
* Now imported just one client (with .ovpn ext.) that had successful connection on my windows 7 PC with latest version of viscosity.
With the successful import of the client there appeared another network adapter- Viscosity Virtual Adapter V9.1
* Checked it's status in properties- 'This device is working properly.' There is no other indication of faulty driver.
* Opened the preference and right click the client to connect it. It only shown 'creating' and disconnected in less than a minute. Following is the connection log-

Mar 07 10:57:42 AM: State changed to Creating...
Mar 07 10:57:46 AM: State changed to Disconnected
Mar 07 11:08:09 AM: State changed to Connecting
Mar 07 11:08:09 AM: Viscosity Windows 1.5.10 (1385)
Mar 07 11:08:10 AM: Running on Microsoft Windows XP Professional
Mar 07 11:08:10 AM: Bringing up interface...
Mar 07 11:08:10 AM: There was a problem activing the interface, Viscosity will attempt to repair it. This process may take a minute or two.
Mar 07 11:08:10 AM: Please try the following if this problem persists: https://www.sparklabs.com/support/troub ... ng_viswin/
Mar 07 11:08:10 AM: State changed to Creating...
Mar 07 11:08:18 AM: Unable to repair interface, cancelling connection attempt.
Mar 07 11:08:18 AM: Please try the following if this problem persists: https://www.sparklabs.com/support/troub ... ng_viswin/
Mar 07 11:08:18 AM: State changed to Disconnected

* Cleared the log, clicked the edit and later the networking tab of the edit connection of the client. Checked 'Send all traffic over VPN connection' check box and saved.
* Tried to reconnect the client but the same response.
* Went to the advanced tab of the edit connection, deleted the line 'dev-node (B08915A3-E4A0-4E78-8AD3-A9D4AAD1A0F5)' saved again and tried to connect the client, nothing new happened.
* One thing more whenever I tried to connect the client there popped up the message from network adapters like this 'Local area area connection 7, A network cable is unplugged'

This was all I could try as I am very new to it. Despite knowing that you don't support for legacy OS, I request you to please help over this matter as there is need to run multiple clients from the tc. Thank you.
Hi ssaahw,

My understanding is that if a user were able to connect to a VPN, every logged in user to this Thin Client host would be effected by that VPN. If you have two people connect, all of a sudden you are going to have network clashes.

If the driver is installing correctly and there are no errors, there is probably a layer somewhere in Windows that is shielding the logged in user from system services like network interfaces. Unless you can find this and remove it, Viscosity probably won't work in Windows Embedded.

Regards,
Eric
Hi Eric,
To be more clear, every single user is provided a TC and they access Windows server (2008, R2) by means of VPN clients installed in these TCs. Before this we used to use Open VPN GUI which gives only one connection at a time. But sometimes it is required to have two or more simultaneous VPN connections at once and so we are switching to Viscosity openvpn client.

Can you please explore '...there is probably a layer somewhere in Windows that is shielding the logged in user from system services like network interfaces.' and how to deploy it.


Regards
Hi ssaahw,

As mentioned earlier, we no longer support the Windows XP (version 5.x) architecture. We are happy to point you in the right direction but I'm afraid we cannot look into this unless you are willing to upgrade to a more recent version of Windows.

One big thing to have a look at is the service. By default it installs as the SYSTEM user, you might have disabled or de-elevated this built in user on your Embedded server, if this is the case you will need to change the user the service is running as to an Admin user.

Alternatively, the desktop may not even be able to contact the service if it is running on a network account, again adjusting the user the service is running as may help.

Regards,
Eric
6 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy