SparkLabs Forum.

Community Help.


Pop-up message at Win startup saying Already Connected.

Hi, I just started using Viscosity today. I'm running Win 7 64 bit, and for Viscosity it looks like Viscosity 1.0.0 (1098). My VPN is TorGuard. So everything went OK with the setup, it connects fine, my speeds are good, no probs there. But then I set up a program Killswitch on one of the gateway locations, using the method given by TorGuard - that is to create a Killswitch.bat file as a Disconnect Script for that particular gateway. So this involves using the Duplicate Connection method as described in the TorGuard instructions here:

https://torguard.net/blog/how-to-setup- ... -torguard/

If I leave it on that newly created connection and restart Windows, Viscosity does auto-start, but I get a Pop-up that says:

"Already Connected. Only one connection can be active at a time. If you wish to connect using this connection profile, please disconnect any other active connections first."

The Viscosity icon in systray does it's normal thing ... it seeks connection and then connects no prob. But I'm not sure why I get that window? If I click OK it goes away. Then, while Windows and TorGuard are running, if I completely Exit TorGaurd from the icon, then re-launch, I get the same error message. I checked Windows Task Manager and only one instance of TorGuard appears in the Processes list. It ends when I close TorGuard, and only a single instance shows back up when I re-launch and still get the error message.

So I discovered that if I don't use that newly created Killswitch connection I don't get the error message. If I restart Windows, Viscosity does indeed restart and gives no error message.

On the newly created connection, if I right click the entry and choose Edit, it's selecting the "Connect when TorGuard opens" that enables that connection to be the default connection and in the process, generates the pop-up.

Has anyone experienced this or know what's going on? Any help appreciated.
Thanks
Hi SalFrank,

Are you ticking "Connect when Viscosity Starts" at the bottom right of the Edit Connection window when you duplicate the connection, or is it already ticked? It seems like there's another connection that has this enabled that might be failing instantly. Try removing any connections you don't use and see if the problem persists.

Regards,
Eric
2 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy