SparkLabs Forum.

Community Help.


VPN DNS not working correctly (Windows 10)

Hi all,

So I've got Viscosity installed and connecting to my VPN successfully in Windows 10 (no adapter creation issues, adapter shows up just fine and I connect successfully). I can connect to internal network resources by IP address. However, if I try to connect to any internal resources by domain name (as hosted by our internal DNS, which is specified as part of our VPN's connection profile) it fails. It seems that Windows 10 is still performing DNS lookups via my primary local network connection's DNS.

Additionally, every time I go to Network Connections > Advanced > Advanced Settings > Adapters and Bindings and try to prioritize the VPN adapter above my other network adapters, the changes don't stick. My user account is an Administrator account and I'm not prompted for administrator access when I open this dialog. I can move adapters up and down in the list and hit the OK button, but as soon as I re-enter the dialog, they're back to how they were before (this also happens after a reboot). All nslookups done at the command line hit the DNS of my internet provider unless I manually specify the IP of my company network's internal DNS.

Any idea what might be going wrong here? The Viscosity log doesn't show any obvious errors on connection, and the "Apply DNS simultaneously" option is checked, so I'm not sure where this is breaking down (whether it's a Windows problem or a Viscosity one). If it's a Windows one, has anyone else encountered an issues where network adapter order settings don't get saved, and if so how did you fix it?

—Matt
Hi Matt,

So I've got Viscosity installed and connecting to my VPN successfully in Windows 10 (no adapter creation issues, adapter shows up just fine and I connect successfully). I can connect to internal network resources by IP address. However, if I try to connect to any internal resources by domain name (as hosted by our internal DNS, which is specified as part of our VPN's connection profile) it fails. It seems that Windows 10 is still performing DNS lookups via my primary local network connection's DNS.


Please try unticking Apply DNS Simultaneously. Windows doesn't support split-DNS like you might be used to on a *nix based system. Instead, it takes the result from the fastest DNS server to respond. Removing Simultaneous DNS will mean that your VPN DNS is set system wide. We are working on a split-DNS like feature, but I'm afraid it is some way off.

Additionally, every time I go to Network Connections > Advanced > Advanced Settings > Adapters and Bindings and try to prioritize the VPN adapter above my other network adapters, the changes don't stick. My user account is an Administrator account and I'm not prompted for administrator access when I open this dialog. I can move adapters up and down in the list and hit the OK button, but as soon as I re-enter the dialog, they're back to how they were before (this also happens after a reboot). All nslookups done at the command line hit the DNS of my internet provider unless I manually specify the IP of my company network's internal DNS.


This feature actually doesn't work anymore as of a semi-recent Windows 10 update. Why Microsoft have chosen to leave it there we don't know, but it's completely ignored by the system. Interface metrics are used instead. If you are on the beta stream, Viscosity will set your VPN interface to the highest priority. This should also resolve your DNS lookup issues, keep in mind that the race type condition that Windows 10 uses for DNS lookups still do exist, and if your VPN DNS is too slow to respond, it will use whichever is the next fastest. Because of this, we do recommend disabling Apply Simultaneous DNS.

To update to the latest beta, go to Preferences -> General, tick Include Beta updates and then click Check Now.

Regards,
Eric
2 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy