SparkLabs Forum.

Community Help.


Very high ping between client and VPN server

Hi,

I have a very weird issue.

My setup:

Server side: OpenVPN Access Server on a Ubuntu 14 VPS (Tagadab UK). I'm the only user of that server, i've setted it up.
Client side: Windows 7 64 bit running Viscosity as a VPN client. No antivirus, no antimalware and no firewall running.

Apparently i've no performance, bandwidth or latency issues at all...90% of the times at least.

But now and then the connection slows down dramatically with very high ping times between server and client.
Just look (pinging from server to client):

1480 bytes from 172.27.224.10: icmp_seq=128 ttl=128 time=76.4 ms
1480 bytes from 172.27.224.10: icmp_seq=129 ttl=128 time=60.5 ms
1480 bytes from 172.27.224.10: icmp_seq=130 ttl=128 time=70.9 ms
1480 bytes from 172.27.224.10: icmp_seq=131 ttl=128 time=74.0 ms
1480 bytes from 172.27.224.10: icmp_seq=132 ttl=128 time=75.4 ms
1480 bytes from 172.27.224.10: icmp_seq=133 ttl=128 time=10926 ms
1480 bytes from 172.27.224.10: icmp_seq=134 ttl=128 time=9920 ms
1480 bytes from 172.27.224.10: icmp_seq=135 ttl=128 time=8912 ms
1480 bytes from 172.27.224.10: icmp_seq=136 ttl=128 time=7906 ms
1480 bytes from 172.27.224.10: icmp_seq=137 ttl=128 time=6900 ms
1480 bytes from 172.27.224.10: icmp_seq=138 ttl=128 time=5892 ms
1480 bytes from 172.27.224.10: icmp_seq=139 ttl=128 time=4884 ms
1480 bytes from 172.27.224.10: icmp_seq=140 ttl=128 time=3877 ms
1480 bytes from 172.27.224.10: icmp_seq=141 ttl=128 time=2869 ms
1480 bytes from 172.27.224.10: icmp_seq=142 ttl=128 time=1861 ms
1480 bytes from 172.27.224.10: icmp_seq=143 ttl=128 time=854 ms
1480 bytes from 172.27.224.10: icmp_seq=144 ttl=128 time=71.1 ms
1480 bytes from 172.27.224.10: icmp_seq=145 ttl=128 time=70.3 ms
1480 bytes from 172.27.224.10: icmp_seq=146 ttl=128 time=65.7 ms
1480 bytes from 172.27.224.10: icmp_seq=147 ttl=128 time=66.5 ms

This is happening random, sometimes after 2 hours of VPN connection, sometimes it doesn't happen at all, sometimes after 30 minutes. Unfortunately when it happens, it's going to happen again and again, a few seconds or minutes later and disconneting and reconnecting doesn't solve it. Sometimes rebooting may work. Sometimes not.

You may wonder it's a network problem: networking/routing is having a temporary issue and so the ping is high. NOT, unfortunately. Cause it doesn't look random at all.

Those pings happen exactly when I load a new webpage or I pause or "unpause" a video stream and so on. When it happens It's clearly related to the user activity. The same activities just before had no influence but suddenly they have...

I did a lot of monitoring and researching and I'm almost sure the problem is client side. One time, for example, I had total relief just changing the VPN client. Unluckily that was just a temporary workaround. In any case the server is not overloaded and its networking is working regularly and at full efficiency.

Someone told me It may be a Windows 7 64 issue/bug, someone suggested me to disable IPV6 (and i did) or to set a different MTU size both on server and client and i did...but no luck.

I'm desperate :) Please help...
Hi Victrix,

Have you spoken to your VPS provider at all? Just because you are the only person using your VPS doesn't mean you are the only person on the server or cluster your VPS is on. There may be heavy load on the server cluster which could be causing these issues, either because of high CPU load across the cluster or network load. We highly recommend you speak to your VPS provider and monitor your servers resource usage when this occurs.

As for other things we can suggest trying, you appear to have tried most things already. Try lowering your MTU to around 1400, 1480 is still quite high. Try different LZO setups to see if compression on or off could help. Try lowering your encryption levels or using lower ciphers if you are using either. I'm afraid these are the only obvious things that the client could be causing, as once the traffic leaves your PC (i.e. OpenVPN has packaged up the traffic), it's out of the control of the client and up the network between your server and your server itself.

I'm afraid though the way your ICMP times are spiking like that and then slowly settling, it does appear as though the server is under high load rather than it being a network or client issue. Try the above suggestions and have a play with your settings and see if anything helps. Try monitoring openvpn.exe through task manager when you experience high pings as well to see if it's memory or CPU usage is spiking.

Regards,
Eric
Hi Eric,

thanks for your kind and quick feedback.

I've contacted my VPS support service.
They checked and confirmed the sporadic high ping over night on my account but the causes aren't clear yet.
Apparently the server isn't overloaded so they instructed me to launch a MTR scan on both sides of the tunnel and then send it to investigate further.

Best regards,

Vic
hi folks!

That's my first Post in this forum.
I know this thread is almost one year old, but I am currently dealing with a similar high ping issue, with an equivalent setup.

here a sample ping

SSL_read: I/O error
Failed to check FreeRDP file descriptor
[email protected] ~ % ping 192.168.20.157
PING 192.168.20.157 (192.168.20.157) 56(84) bytes of data.
64 bytes from 192.168.20.157: icmp_seq=1 tt1=127 time=1896 ms
64 bytes from 192.168.20.157: icmp_seq=2 tt1=127 time=2986 ms
64 bytes from 192.168.20.157: icmp_seq=3 tt1=127 time=2058 ms
64 bytes from 192.168.20.157: icmp_seq=4 tt1=127 time=1227 ms
64 bytes from 192.168.20.157: icmp_seq=5 tt1=127 time=796 ms
64 bytes from 192.168.20.157: icmp_seq=6 tt1=127 time=1043 ms
64 bytes from 192.168.20.157: icmp_seq=7 tt1=127 time=3808 ms
64 bytes from 192.168.20.157: icmp_seq=8 tt1=127 time=4614 ms
64 bytes from 192.168.20.157: icmp_seq=9 tt1=127 time=4710 ms
64 bytes from 192.168.20.157: icmp_seq=11 tt1=127 time=3229 ms
64 bytes from 192.168.20.157: icmp_seq=12 tt1=127 time=2403 ms
64 bytes from 192.168.20.157: icmp_seq=13 tt1=127 time=1563 ms
64 bytes from 192.168.20.157: icmp_seq=14 tt1=127 time=2133 ms
64 bytes from 192.168.20.157: icmp_seq=15 tt1=127 time=1521 ms
64 bytes from 192.168.20.157: icmp_seq=16 tt1=127 time=512 ms
64 bytes from 192.168.20.157: icmp_seq=17 tt1=127 time=236 ms
64 bytes from 192.168.20.157: icmp_seq=18 tt1=127 time=1218 ms
64 bytes from 192.168.20.157: icmp_seq=19 tt1=127 time=2658 ms

I just wanted to ask if your issue has been fixed, and if so, what you have done resolve it.

thanks a lot
Hi tomwwabo,

Sorry to reply so late, I hope in the meantime you have fixed it.

I have no longer that issue: I can't tell you a sure way to fix it because I tried so many solutions I am not even sure which have done what :)

But i'm 90% confident it was related to the OpenVPN driver packaged with Viscosity.
Indeed, when I was still running Windows 7 64-bit, using the "legacy driver"of Viscosity instead of the default/recommended one solved the problem for me.

Now i'm running Windows 10 64 bit with the default settings of Viscosity and never had an issue after switching to the new OS / Viscosity version.
5 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy