SparkLabs Forum.

Community Help.


"Connection is not reachable" on Win 7 but works on Mac

Just downloaded the latest version and imported the connection from Viscosity on my Mac and I get "Connection is not reachable". I can connect fine on the mac from the same location (my house).

I can ping the vpn host from windows. I tried disabling the windows firewall completely with no luck. I also added a rule and added both the executible and service to it. Not sure what else to try. My config and log from the windows client is below.

Thanks!

Code: Select all

Oct 12 02:25:01: Viscosity 1.4.0 (1159)
Oct 12 02:25:01: Running on Microsoft Windows 7 Ultimate
Oct 12 02:25:01: Checking reachability status of connection...
Oct 12 02:25:01: Connection is not reachable. Disconnecting.
Oct 12 02:25:01: State changed to Disconnected

Code: Select all

#-- Config Auto Generated By Viscosity --#

#viscosity startonopen false
#viscosity dhcp true
#viscosity dnssupport true
#viscosity name XXXXXXX
#viscosity ipv6 false
remote XX.XX.XX.XX 1194 udp
pull
comp-lzo adaptive
ca ca.crt
redirect-gateway def1
dev tun
cert cert.crt
tls-client
key key.key
mute-replay-warnings
float
cipher BF-CBC
route-delay 5
dev-node {XXXXXXX-BEC5-4460-XXXX-0355FC2C93C5}
Hi ceddybu,

This one didn't crop up in our testing and is only effecting a small portion of our users. We sincerely apologise for any disruption it has caused. Below is a link to a beta build we've put up. It is the 1.4 release with what we hope is a fix for the problem you have described. Let us know if it solves the problem.

viewtopic.php?f=7&t=482

Cheers,

Eric
The connection gets farther, but there is still a problem. I tried "clearing" all the files under the authentication tab to make sure the correct files are being loaded. Any ideas?

Thanks for the response!

Code: Select all

Oct 12 03:14:51: State changed to Connecting
Oct 12 03:14:51: Viscosity 1.4.0 (1160)
Oct 12 03:14:51: Running on Microsoft Windows 7 Ultimate
Oct 12 03:14:51: Checking reachability status of connection...
Oct 12 03:14:52: Connection is reachable. Starting connection attempt.
Oct 12 03:14:52: Bringing up interface...
Oct 12 03:14:52: OpenVPN 2.2.2 Win32-MSVC++ [SSL] [LZO2] [PKCS11] built on Jan  4 2012
Oct 12 03:14:56: IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Oct 12 03:14:56: WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Oct 12 03:14:56: NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Oct 12 03:14:56: Cannot load certificate file cert.crt: error:02001005:system library:fopen:Input/output error: error:20074002:BIO routines:FILE_CTRL:system lib: error:140AD002:SSL routines:SSL_CTX_use_certificate_file:system lib
Oct 12 03:14:56: Exiting
Oct 12 03:14:57: State changed to Disconnected
Hi ceddybu,

Do you know if you're using a 32bit or 64bit version of Windows 7 there?

Cheers,

Eric
Eric, I'm running 64-bit version of windows
Thanks. We think we know what might be going on, we'll have another beta up shortly.

Thanks for your patience!

Eric.
Hi ceddybu,

Please let us know if this new beta helps:
viewtopic.php?f=7&t=482

Regards,

Eric
7 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy