Unable to disable Viscosity DNS

Got a problem with Viscosity or need help? Ask here!

Viscosity1

Posts: 3
Joined: Thu May 16, 2019 1:02 am

Post by Viscosity1 » Thu May 16, 2019 1:07 am
Hi,

I need to disable Viscosity's DNS system.

I've checked the "Use Windows DNS System for Full DNS" but all my adapters are still getting their DNS settings rewritten to ::1 and 127.0.0.1

Doug

Eric

User avatar
Posts: 863
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Thu May 16, 2019 11:13 am
Hi Doug,

As the option suggests, you will need to set your configuration to Full DNS mode. To do this, edit the connection and go to the Networking tab, and change the DNS Mode drop down to Full. Remember to click Save.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

Viscosity1

Posts: 3
Joined: Thu May 16, 2019 1:02 am

Post by Viscosity1 » Thu May 16, 2019 8:57 pm
Eric,

Thanks for your reply. Is this the only way? I need to keep my "wired" adapter independent.

This setup works fine with the OpenVPN gui?

Doug

Eric

User avatar
Posts: 863
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Fri May 17, 2019 5:46 pm
Hi Doug,

Yes, this is currently the only way to not use Viscosity's DNS system. If you have a query on a particular use case, you're welcome to let us know and we can see if we can find a better workaround for you.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

Viscosity1

Posts: 3
Joined: Thu May 16, 2019 1:02 am

Post by Viscosity1 » Fri May 17, 2019 9:58 pm
Eric,

Thanks again for the reply.

We just need to disable Viscosity DNS. It is a level of overhead that is not needed.
Our only option now is to go back to OpenVPN GUI.

Thanks for your help.

Doug
5 posts Page 1 of 1