Viscosity 1.7.14 with OpenSC 0.19 CKR_USER_NOT_LOGGED_IN

Got a problem with Viscosity or need help? Ask here!

[email protected]

Posts: 4
Joined: Wed Jan 16, 2019 3:39 pm

Post by [email protected] » Wed Jan 23, 2019 5:10 am
Hello,

Using the latest version of Viscosity with OpenSC 0.19.

I have client certificates stored in slots 9A and 9C on a YubiKey. Up until version 1.7.12, I was able to connect using certs in either slot. After upgrading I can detect and select the certificate in slot 9C, but when I try to connect, I get "Method C_Sign returned CKR_USER_NOT_LOGGED_IN".

Do you have any advice on how to solve this problem?

Thanks!
Al

Eric

User avatar
Posts: 863
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Wed Jan 23, 2019 10:31 am
Hi Al,

OpenVPN as of Viscosity 1.7.13 and on wards now ships with a 64-bit OpenVPN binary for x64 systems. This means supporting libraries, like PKCS#11 libraries, will now need to be 64-bit also, you would have needed 32-bit in the past.

I'm afraid we weren't aware that you could use 9c for PKCS#11, the spec from Yubikey seems to indicate only 9a can be used. I'm getting exactly the same behaviour as you though with OpenSC 0.19. Viscosity is doing everything right, it seems to be OpenSC that is having the issue.

However, downgrading to OpenSC 0.16 has resolved the issue for me, I uninstalled 0.19 and grabbed the OpenSC-0.16.0-win64_vs12-Release.msi package here - https://github.com/OpenSC/OpenSC/releases/tag/0.16.0

and used the dll here after installing as - "C:\WINDOWS\System32\opensc-pkcs11.dll"

Please give this a try and let us know how you get on.

We'll try and make some time to dig into OpenSC and see if we can find out what is going on with the latest version. Unfortunately this isn't the first oddness we've encountered with OpenSC.

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

[email protected]

Posts: 4
Joined: Wed Jan 16, 2019 3:39 pm

Post by [email protected] » Wed Jan 23, 2019 11:11 am
Hello Eric,

Yes! That worked. Thanks much for the quick solution!

Cheers,
Al

vishal

Posts: 1
Joined: Mon Aug 13, 2018 8:21 pm

Post by vishal » Thu Jan 24, 2019 3:24 pm
Hello Team

Viscosity current version is not working with Yubi key .

Thanks
Vishal

Eric

User avatar
Posts: 863
Joined: Sun Jan 03, 2010 3:27 am

Post by Eric » Thu Jan 24, 2019 7:08 pm
Hi Vishal,

We will need some more information. Could you please post a complete copy of your log after the problem occurs - https://sparklabs.com/support/kb/articl ... envpn-log/

Regards,
Eric
Eric Thorpe
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

[email protected]

Posts: 4
Joined: Wed Jan 16, 2019 3:39 pm

Post by [email protected] » Thu Feb 28, 2019 6:43 am
Hello everyone,

Just wanted to post an update.

Eric resolved the issue I was having with the beta version of 1.7.15 (build 1596) and OpenSC 0.17. It also resolved a longstanding problem with connections remaining connected but not passing traffic.

Eric was most helpful throughout the process, tirelessly trying different solutions until the problem was fixed. Kudos to Sparklabs for their outstanding support.
6 posts Page 1 of 1