SparkLabs Forum.

Community Help.


Beta: Latest Build of Viscosity for Mac

Hi donza,

What does your "scutil --dns" output look like while connected to your VPN connection (when you are having DNS trouble)? Information about running this command can be found in the "Checking Which DNS Servers Are Being Used" section at:
http://www.sparklabs.com/support/config ... ins_setti/

Cheers,
James
James wrote:
Hi donza,

What does your "scutil --dns" output look like while connected to your VPN connection (when you are having DNS trouble)? Information about running this command can be found in the "Checking Which DNS Servers Are Being Used" section at:
http://www.sparklabs.com/support/config ... ins_setti/

Cheers,
James


Hi James,

"Resolver #1" has my ISP's DNS servers, which won't answer when VPN is active.
"Resolver #2" has my VPN connection's valid DNS server, which answers if I manually query "dig @x.x.x.x http://www.google.com A" where x.x.x.x is the DNS server in "Resolver #2".

So it looks like that for some reason GUI apps don't even attempt to use "Resolver #2".
Below is the output (with actual IPs hidden):

Code: Select all

DNS configuration

resolver #1
  search domain[0] : tun0.viscosity
  search domain[1] : Cisco
  nameserver[0] : a.a.a.a
  nameserver[1] : b.b.b.b
  if_index : 4 (en0)
  flags    : Request A records

resolver #2
  domain   : tun0.viscosity
  nameserver[0] : x.x.x.x
  flags    : Request A records
  reach    : Reachable
  order    : 100400
Hi donza,

It sounds like you have the "Apply DNS settings simultaneously" option turned on (under Preferences->Advanced). Turning this option off should give you the behaviour you're after.

Cheers,
James
James wrote:
Hi donza,

It sounds like you have the "Apply DNS settings simultaneously" option turned on (under Preferences->Advanced). Turning this option off should give you the behaviour you're after.

Cheers,
James


Thanks James! I'm not sure when that setting got enabled, but disabling it did the trick.
Hello,

After updated to latest beta release today, I can't connect to server with following error log:

Code: Select all

Nov 04 15:43:35: Viscosity Mac 1.5.3b2 (1244)
Nov 04 15:43:35: Viscosity OpenVPN Engine Started
Nov 04 15:43:35: Running on Mac OS X 10.10
Nov 04 15:43:35: ---------
Nov 04 15:43:35: Checking reachability status of connection...
Nov 04 15:43:35: Connection is reachable. Starting connection attempt.
Nov 04 15:43:35: OpenVPN 2.3.5 x86_64-apple-darwin [SSL (OpenSSL)] [LZO] [PKCS11] [MH] [IPv6] built on Nov  3 2014
Nov 04 15:43:35: library versions: OpenSSL 1.0.1j 15 Oct 2014, LZO 2.08
Nov 04 15:43:38: WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Nov 04 15:43:38: ******* WARNING *******: null cipher specified, no encryption will be used
Nov 04 15:43:38: Assertion failed at crypto_openssl.c:525


Any help would be greatly appreciated. Thank you.
Hi NanoG6,

It appears there is a bug in OpenVPN 2.3.5 if encryption is disabled, which is what you're running into. We'll see if we can come up with a patch or workaround for it - in the meantime I'd recommend dropping back to the stable release which comes with OpenVPN 2.3.4.

Cheers,
James
166 posts

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy