resolv.conf nuked

Got a problem with Viscosity or need help? Ask here!

ev


Post by ev » Sat Jan 17, 2009 7:01 pm
Hi,

This morning I was forced to use an old analog connection via the Apple USB modem; the software created a resolv.conf like this:
Code: Select all
nameserver 123.456.789.012
nameserver 123.456.789.013
This resolv.conf does not have a domain directive, as you can see. Then I activated Viscosity, did some work and upon turning off the VPN I found that /etc/resolv.conf was removed and scutil's output listed the first resolver block as empty. The usual broadband connection populates resolv.conf with a domain directive and a couple of nameserver; my Python is a bit rusted, so don't know if something went wrong in the dns up/down script.

James

User avatar
Posts: 1898
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue Feb 03, 2009 2:09 am
Hi ev,

I'll look into it and see if it can be replicated, and if so resolved.

We're in the process of overhauling the DNS system for a version 1.1 release, which should make it much more reliable than the current method.

Regards,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

ivarh

Posts: 2
Joined: Tue Jul 21, 2009 8:42 am

Post by ivarh » Tue Jul 21, 2009 9:16 am
Hi, I am running v 1.0.5 and am seeing the same problem. I am connected to the internet using a 3 (Local australian cellphone company) USB modem.
When I log in to their network i have the following resolv.conf:
nameserver 10.176.66.71
nameserver 10.188.66.103

scutil --dns reports (the first few entries):
DNS configuration

resolver #1
nameserver[0] : 10.176.66.71
nameserver[1] : 10.188.66.103
order : 200000

resolver #2
nameserver[0] : 10.176.66.71
nameserver[1] : 10.188.66.103
order : 100000


After connecting to my openvpn server and If I uncheck alternate dns support i end up with this resolv.conf and output from scutil --dns:
--------

# begin tun0 OpenVPN tunnel modifications
nameserver 74.207.241.5
search ih36.net
# end tun0 OpenVPN tunnel modifications
--------

scutil --dns:
DNS configuration

resolver #1
domain : ih36.net
nameserver[0] : 74.207.241.5
order : 200000

At this point everything works until i disconnect the VPN session and my resolv.conf dissapears rendering dns resolution non working.

If I enable alternate dns handling this happens when i connect to my VPN server:
resolv.conf:
-----------
# nameserver 10.176.66.71
# nameserver 10.188.66.103

# begin tun0 OpenVPN tunnel modifications
nameserver 74.207.241.5
search ih36.net
# end tun0 OpenVPN tunnel modifications
-------------
and scutil --dns:
resolver #1
search domain[0] : ih36.net
nameserver[0] : 10.176.66.71
nameserver[1] : 10.188.66.103
order : 200000

resolver #2
domain : ih36.net
nameserver[0] : 74.207.241.5
order : 100800

As you can see it will still use my ISP's dns servers first and since they are on a private network they cannot be reached through the DNS.

But when i disconnect i am left with the ISP resolv.conf and a working dns setup.

I am running the latest version of 10.5.7

-Ivar

James

User avatar
Posts: 1898
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Tue Jul 21, 2009 9:33 pm
Hi Ivar,
At this point everything works until i disconnect the VPN session and my resolv.conf dissapears rendering dns resolution non working.
Does the "scutil --dns" command have any DNS servers listed after you disconnect? If you go to Preferences->Advanced and tick "Reset network interfaces on disconnect", does that resolve the issue?
As you can see it will still use my ISP's dns servers first and since they are on a private network they cannot be reached through the DNS.
This is the expected behaviour of the Alternate DNS support scripts - they simply append the VPN DNS servers to the list of available DNS servers. It is recommend you use the default DNS support (which overrides the DNS servers with the VPN specified ones).

Cheers,
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs

ivarh

Posts: 2
Joined: Tue Jul 21, 2009 8:42 am

Post by ivarh » Thu Jul 23, 2009 10:52 am
No, after logging off I have no resolvers in the scutil --dns output.

I have made a functioning workaround though. I have defined routes to the 10 network through the original network connection. This allows my host to reach the ISP dns servers while connected to the VPN. this is with alternate dns support enabled.
5 posts Page 1 of 1