Keeping connection alive?

Got a problem with Viscosity or need help? Ask here!

Undisclosedpower

Posts: 1
Joined: Tue Dec 30, 2008 8:49 am

Post by Undisclosedpower » Tue Dec 30, 2008 8:59 am
I have a vpn connection open to my home vpn server at pretty much all times, even when i'm within my home network. When i'm outside of my home network any traffic I send to my home ips gets routed over the vpn, thus keeping the connection alive. However when i'm on my home network traffic to my home ips do not get routed via the vpn so it dies every few minutes and reconnects displaying a growl notification.

I have played with the ping settings to try and figure out how on earth to keep the connection alive when i'm internal to my network. But I've had no Joy. I know I could turn it off, but I prefer having the connection always open, so that wherever I open my laptop I know i'll be connected to my home with no effort.

How can I keep this connection alive?

I was using tunnelbrick on this machine with 10.4 and I never had, or maybe since tunnelbrick didn't growl never noticed this issue before. I've just upgraded to leopard (hard disk failure) and thought i'd try this out and aside from this issue i'm loving it, so is there anyway to resolve it?

Thanks In advance.

UDP.

James

User avatar
Posts: 1908
Joined: Thu Sep 04, 2008 9:27 pm

Post by James » Thu Jan 08, 2009 5:36 pm
It should be possible to keep the connection alive using the OpenVPN ping command. Do you have both the server and the client (Viscosity) setup to send out ping commands (say every 30 seconds as a test)? Are you using the ping-restart option on either the client or the server?

If your connection is indeed dropping out due to inactivity, then setting a ping value of 60 seconds, and a ping-restart value of 120, for both the server and the client, should do the trick.

Cheers
James
James Bekkema
Viscosity Developer

Web: http://www.sparklabs.com
Support: http://www.sparklabs.com/support
Twitter: http://twitter.com/sparklabs
2 posts Page 1 of 1