SparkLabs Forum.

Community Help.


Icon being strange and annoying in High Sierra (v1.7.12)

I'm not sure if it's just my machine but since the latest update (v1.7.12) the Viscosity icon in the menu bar has not been behaving correctly on my MBP running High Sierra. It seems to get stuck highlighted and then can be a pain to use, although the app is still useable. I tested it with and without Bartender running which made no fundamental difference. (Although the dropdown menu flashes when switching between bartender modes, making it more annoying.)

It's difficult to explain so I knocked together a GIF although I'm not sure if that helps either... :?

Image

I've not tried reinstalling the app or installing it on another machine yet but will give that a go if no one else can reproduce the issue.

Like I say the app is still useable and still as great as it always has been aside from this minor annoyance which I'm guessing will go away once I upgrade to Mojave.

Thanks.
Hi pugu,

Although the dropdown menu flashes when switching between bartender modes, making it more annoying.

The latest beta version of Viscosity contains a change that should help with this one:
https://www.sparklabs.com/support/kb/ar ... -versions/

In regards to the weird clicking behaviour, that's certainly quite strange and undesirable. I'm afraid that's not something we've been able to produce on any of our 10.13 test machines, or have had any other reports of. You mention you've tried it without Bartender running: have you tried with it temporarily uninstalled?

Also, on 10.13 the Notification Center icon (on the right hand side) will typically disable while Viscosity's menu is open. However I notice that isn't happening in your gif, which points to something strange going on. Do you notice any difference in the menu behaviour depending on what application you have in the foreground? (I'm wondering if an application may be refusing to give up active status to the Viscosity menu).

Cheers,
James
I am having the same problem in macOS 10.12.6. It started a couple up updates ago. I'm on 1.7.12 now.

Example: When you select the menubar item and hover over ANY entry in the list, the list item description disappears (I assume it's turning white) and only the icon remains. The descriptions reappear when you move to the next item in the list.

My guess is that it's only happening in 10.12
Hi Thorgrim,

Thanks for the report. It appears if you have "Reduce transparency" option enabled (in the Accessibility section of System Preferences) you may see the blue menu item highlight fail to display on macOS 10.11 and 10.12. We've now fixed this in the latest beta version:
https://www.sparklabs.com/support/kb/ar ... -versions/

Cheers,
James
I do have Increase Contrast and Reduce Transparency turned on. My eyes now being "old" :-/

I can wait for the next regular update.

Thanks for getting it fixed.
5 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy