SparkLabs Forum.

Community Help.


Need help connecting to VPN using Viscosity on Mac

I'm running Mac OS 10.13.6 and Viscosity 1.7.11. I received a .opvn file for connecting and cert and key files. It seems like it wants to connect but is having trouble authenticating. Here is the log message I get when trying to connect which repeats itself until I hit disconnect. Let me know if yall have any suggestions..

2018-10-10 13:36:32: Running on macOS 10.13.6
2018-10-10 13:36:32: ---------
2018-10-10 13:36:32: State changed to Connecting
2018-10-10 13:36:33: WARNING: No server certificate verification method has been enabled. See http://openvpn.net/howto.html#mitm for more info.
2018-10-10 13:36:33: TCP/UDP: Preserving recently used remote address: [AF_INET]75.109.166.189:12974
2018-10-10 13:36:33: UDP link local: (not bound)
2018-10-10 13:36:33: UDP link remote: [AF_INET]75.109.166.189:12974
2018-10-10 13:36:33: State changed to Authenticating
2018-10-10 13:36:33: VERIFY ERROR: depth=1, error=self signed certificate in certificate chain: C=TW, ST=TW, L=Taipei, O=netgear, OU=netgear, CN=netgear, [email protected]
2018-10-10 13:36:33: OpenSSL: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed
2018-10-10 13:36:33: TLS_ERROR: BIO read tls_read_plaintext error
2018-10-10 13:36:33: TLS Error: TLS object -> incoming plaintext read error
2018-10-10 13:36:33: TLS Error: TLS handshake failed
2018-10-10 13:36:33: SIGUSR1[soft,tls-error] received, process restarting
2018-10-10 13:36:33: Viscosity Mac 1.7.11 (1463)
2018-10-10 13:36:33: Viscosity OpenVPN Engine Started
Hi Joe,

The certificate in the configuration you received is missing, damaged or invalid. You will need to contact who you received the .ovpn file from and request an updated configuration.

Regards,
Eric
Thanks for replying Eric. I will see if I can get updated config files from the administrator, but are you sure there's nothing else I can do? The same files seem to work fine for my co workers and they are using OpenVPN 2.4.4 with Windows. Also want to point out that they had to rename TAP-Windows Adapter in the Network Connections to NETGEAR-VPN. Would I need to do anything similar like rename anything? Any other info would help and in the meantime I will try to get updated config files. Thanks again.
If you've configured the connection manually please ensure that the Certificate Authority (CA) file and the user Certificate (Cert) files have not been mixed up. If you're sure they're correct I'm afraid you will need to get in touch with the administrator of the VPN server for updated files.

Cheers,
James
4 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy