SparkLabs Forum.

Community Help.


Reconnect attempts despite options disabled

I have disabled "Reconnect active connections on wake" in general preferences and "Automatically reconnect if disconnected" in the settings for the connection in question.

Sometimes I am connected to the VPN and then... time passes, maybe I'm idle or the laptop sleeps or something else, I haven't kept track because I'm not paying attention at this point in the process. Some time later, I get a notification from Viscosity that my credentials have been rejected which implies to me that a reconnect attempt was made. I also then find an email from my two factor authentication provider saying I've been locked out for multiple failed login attempts.

Why is Viscosity attempting to reconnect at all, why am I not getting a notification when I lose the connection, and why is it attempting repeatedly rather than letting me know the first time it fails?
Hi sparr,

A couple of points which should help:

1. It's unlikely that your connection is actually reconnecting. By default OpenVPN will renegotiate/re-key the session every 60 minutes for security reasons. However if two-factor authentication is enabled and poorly configured this can result in you needing to re-authenticate via your two-factor method every hour as well. This can be avoided by either disabling renegotiation (or changing it to a longer time) using the "reneg-sec" option, or by making use of auth-tokens. You should get in touch with your VPN Provider in this instance:
https://www.sparklabs.com/support/kb/ar ... ovider-is/

2. If your VPN connection is actually dropping, depending on your connection's settings OpenVPN itself may try to re-establish it. To have reconnecting completely controlled by Viscosity you can add the command "remap-usr1 SIGTERM" (without quotes) as an advanced command:
https://www.sparklabs.com/support/kb/ar ... -commands/

Cheers,
James
2 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy