SparkLabs Forum.

Community Help.


Config on the command line

Hi,

I'm trying to configure the inactivity timeout via the command line on the mac client.

I have tried using the defaults command, and it successfully puts in the values that I want (IdleTime = 60; and DisconnectOnIdle = 1) but the GUI of viscosity never shows the changes. If I go into the GUI and check the box and set the idle timeout, it changes in the plist file and works. For some reason, when I make the changes to the plist file with defaults, it doesn't actually do anything. I've tried killing the process and restarting it, but viscosity doesn't pick up the changes.

Any ideas?
Hi sudoSamurai,

Using the "defaults" command is the correct method, for example something like "defaults write com.viscosityvpn.Viscosity IdleTime -int 20". This should be reflected immediately in the GUI if you close and re-open Viscosity's Preferences window, but I'd recommend quitting and re-launching Viscosity to ensure it has actually been applied and being used correctly.

Editing the plist file directly will not work due to the way macOS caches preferences data (it's necessary to log out and log back into the computer to force macOS to re-read the plist data).

Cheers,
James
2 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy