SparkLabs Forum.

Community Help.

Server IP vs Public IP, Quick Question!

Hello! I have been using Viscosity for a while now. I have one question that I'm trying to better understand. Is the Server IP supposed to be the same as the Public IP for OpenVPN subscription VPNs (like PIA, etc..)? I could have sworn the other day that the Server IP was the same as the Public IP, but now it seems to differ when I check what my Public/External IP is on

Have the two always been different? Are there reasons why they would differ? Or should they supposed to be the same? It's not a big issue but I can't quite find too much information on this.
Hi b0rd2dEAth,

The Server IP Viscosity lists is the IP address of the OpenVPN server you are connected to (i.e. it's the IP address Viscosity is sending encrypted traffic to). While in most instances the Server IP and your "Public IP" address will be the same when you're sending all traffic through the VPN connection, they don't have to be and probably won't be in more complex server setups.

Basically if the VPN server you're connected to is also acting as a router for all VPN traffic, its external IP address and your Public IP address will be the same. This is accomplished by the OpenVPN server using NAT for all VPN traffic. The vast majority of VPN servers are configured this way.

However, the VPN server could also be forwarding your traffic to a different router or server (that is performing the NAT to the wider internet), in which case your Public IP address will be that of the different router instead. Another possibility is some commercial VPN service providers might assign you your own publicly routable IP address (instead of using NAT), in which case your Public IP address could be the same as your Client IP address.

Hey! Thanks for the response.

I use stunnel with my home vpn and the server IP connects to local along with stunnel itself. I just wasn't 100% sure about other paid vpns because occasionally it will have the same public IP and server IP and occasionally it didn't. If it's something to do with the configurations of the servers themselves then that should definitely explain it. I thought for a sec viscosity was connecting to the wrong server or something lol. But yeah, thanks for clearing that up.
3 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy