SparkLabs Forum.

Community Help.


> 1.6.8 Connectivity Problems

I'm not sure if this is the right place to ask but I was just wondering if there was a known issue with Viscosity versions > 1.6.8 that would explain the connectivity issues we're seeing. To summarize, with versions up to and including 1.6.8, the connection to our VPN is 100% stable, but with every version since then, the connection is established but is very inconsistent. Some services are accessible some of the time, others are always accessible, while still others aren't at all. There doesn't seem to be any pattern to it that I can see. This happens on both the Mac and Windows version of Viscosity. The VPN server uses OpenVPN 2.3.2 on Ubuntu 14.04.5 LTS. I can also post my OpenVPN server configuration if that would be helpful.

Thanks.
Hi cortic,

It sounds likely there is a compression mismatch between the server and clients. Please see:
http://www.sparklabs.com/support/kb/art ... ader-byte/

Cheers,
James
That definitely appears to be the problem. Unfortunately, I couldn't find any configuration that makes the latest version of Viscosity work with our OpenVPN 2.3 server. So it seems like our only option may be to upgrade to OpenVPN 2.4 at some point.

Thanks.
Hi cortic,

You can change the OpenVPN version to 2.3 under Preferences->Advanced, however as Viscosity's editor is designed for OpenVPN 2.4 you'll need the remove the "compress" command from the configuration and restore the comp-lzo setting (easiest method is to re-import your configuration).

Cheers,
James
Is there a way to set a version for an individual connection? I've got a couple old servers that are stuck on 2.3, and need the client set to 2.3 in order to work properly...but I'd like to be able to use 2.4 (and newer) on newer devices, so I don't want to set the entire client to 2.3.
Hi CanuckMSP,

It's possible to override the version used on a per-connection basis using the "#viscosity protocol-version 2.3" command, however use of this is not recommended. OpenVPN 2.4 is perfectly capable of connecting to a server running 2.3: it's not necessary that the versions match.

If you are having difficulty using the servers running 2.3 when using 2.4 in Viscosity, then it's most likely due to a compression setting conflict, which can be fixed up without needed to change the versions. For more information please see:
https://www.sparklabs.com/support/kb/ar ... ader-byte/

Cheers,
James
Hi James,

Adjusting the compression worked great.

Thanks!
7 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy