SparkLabs Forum.

Community Help.

Can't route all traffic to the vpn

Hi all!

I am having difficulties accessing the remote network through the vpn when using the viscosity client on my mac, but everything works when using the official ovpn client on my win computer so I am getting confused.

I am configuring the routers I am deploying to push the redirect gateway in this fashion:
set interfaces openvpn vtun0 openvpn-option "--push "redirect-gateway def1"
set interfaces openvpn vtun0 openvpn-option "--push route"
set interfaces openvpn vtun0 server subnet
set interfaces openvpn vtun0 openvpn-option "--push dhcp-option DNS"

This usually works fine and my clients are passing all the traffic through the vpn. Accessing the remote router which is usually on common ip also works fine and I am not reaching my home router.

Yesterday I have purchased the Viscosity so I can connect to the remote sites from my mac as well, imported my ovpn profiles and hoped I am ready to go.... - I was not...

I was able to connect successfully but I wasn't able to reach any of the remote addresses (although I saw them on the ip scan and my public ip was the public ip of the remote site). When trying to reach the remote router, it was my router who responded etc..... Tried to check the "Send all the traffic blah blah" in the Viscosity connection setup but no luck.
So I switched back to my win machine, dialed in using the same ovpn profile and everything worked as expected...

Any idea why this happens? - why it works fine with any win but not on my osx?

Hi maara,

I recommend checking the OpenVPN log for any error messages or warnings: ... envpn-log/

If nothing stands out in the log, then I recommend checking whether there may be a routing or DNS issue: ... connection

2 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy