SparkLabs Forum.

Community Help.


Replace OpenVPN Binary Version

My VPN service provider instructed me to use strictly the OpenVPN version 2.3.2.

Is it possible to replace the Viscosity openVPN client with a binary of that version? How?

MacOS Sierra Viscosity 1.6.8
Hi Manologin,

If true I'd recommend finding another VPN Provider: version 2.3.2 of OpenVPN is quite old and several important security changes have been included in successive versions. I'd consider version 2.3.2 insecure. The current latest version of the 2.3 branch is 2.3.14.

Newer versions of OpenVPN are backwards compatible with OpenVPN servers using older versions. If your VPN Provider is insisting that you use the same version they have installed on their server I'm afraid they are misinformed.

However you can replace Viscosity's copy of OpenVPN if needed. It can be found at "/Library/Application Support/Viscosity/openvpn". When replacing it you'll need to ensure that the file permissions exactly match, otherwise Viscosity will detect the mismatch and replace it.

Cheers,
James
2 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy