SparkLabs Forum.

Community Help.


VPN Connects but not traffic routed until I restart my mac

HI Support,
VPN connects without any problem. But doesn't route any traffic until I restart my PC. Have tried many. Adding a delay 20 seconds on the Advanced tab. Nothing helped. Let me know.

Feb 07 22:29:24: Viscosity Mac 1.6.8 (1370)
Feb 07 22:29:24: Viscosity OpenVPN Engine Started
Feb 07 22:29:24: Running on Mac OS X 10.12.3
Feb 07 22:29:24: ---------
Feb 07 22:29:24: Checking reachability status of connection...
Feb 07 22:29:24: Connection is reachable. Starting connection attempt.
Feb 07 22:29:27: OpenVPN 2.3.14 x86_64-apple-darwin [SSL (OpenSSL)] [LZO] [PKCS11] [MH] [IPv6] built on Jan 14 2017
Feb 07 22:29:27: library versions: OpenSSL 1.0.2j 26 Sep 2016, LZO 2.09
Feb 07 22:29:30: Control Channel Authentication: using '/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T/connection.WUeQJk/ta.key' as a OpenVPN static key file
Feb 07 22:29:30: UDPv4 link local (bound): [undef]
Feb 07 22:29:30: UDPv4 link remote: [AF_INET]155.12.12.214:2295
Feb 07 22:29:30: WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Feb 07 22:29:31: [XXXXX] Peer Connection Initiated with [AF_INET]XXX.XXX.XXX.XXX:XXXX
Feb 07 22:29:34: Opening utun (connect(AF_SYS_CONTROL)): Resource busy
Feb 07 22:29:34: Opening utun (connect(AF_SYS_CONTROL)): Resource busy
Feb 07 22:29:34: Opening utun (connect(AF_SYS_CONTROL)): Resource busy
Feb 07 22:29:34: Opened utun device utun3
Feb 07 22:29:34: do_ifconfig, tt->ipv6=0, tt->did_ifconfig_ipv6_setup=0
Feb 07 22:29:34: /sbin/ifconfig utun3 delete
Feb 07 22:29:34: NOTE: Tried to delete pre-existing tun/tap instance -- No Problem if failure
Feb 07 22:29:34: /sbin/ifconfig utun3 X.X.X.X X.X.X.X netmask 255.255.255.248 mtu 1500 up
Feb 07 22:29:34: Initialization Sequence Completed
Feb 07 22:29:34: DNS mode set to: Off
Hi rosarioarun,

Your log indicates that DNS is turned off - you may want to check if that's what you want, as it could affect the ability to use the VPN connection.
http://www.sparklabs.com/support/kb/art ... #dns-modes

Also judging by the adapter number (utun3) it looks possible that you may have one or more other VPN connections/tunnels operational on your computer at the same time. Please ensure that any other such software you may be using will not conflict with your connection in Viscosity.

Finally, if you mean you have to reboot your computer after you disconnect to restore network connectivity, please see:
http://www.sparklabs.com/support/kb/art ... connected/

Cheers,
James
1. utun3. There is no other VPN or vpn softwares installed. i have removed all of them long before purchasing viscosity.
2. DNS. I access specific private IPs within the VPN. DNS is not needed or shouldnt affect anything.
3. I have tried the reset network interfaces option. It didn't help.

I push a route to the pc from the server on successful connect. I see that route added

<VPN LANNetwork> < VPN GW> UGSc 2 2 utun2

the VPN connect logs says utun3, while the route says utun2. Why is that ?
Hi rosarioarun,

As mentioned it sounds like there are multiple VPN connections/tunnels running. The utun2 adapter is being created by another connection/tunnel. macOS will often create utun0 and utun1 for iCloud services, but it won't go beyond that. If you are connecting multiple connections at once in Viscosity you'll need to ensure their IP ranges and routes do not clash with each other.

If you're only connecting a single connection at once then the other VPN connection is coming from elsewhere on your machine - try restarting your computer to ensure that there isn't a stuck connection or process running in the background. If you're still seeing the extra adapters, even when Viscosity isn't running, then I'd recommend seeing whether there is any other software that could still be creating a link in the background. Perhaps another tool hasn't been completely uninstalled.

You can view the network adapters active on your computer by entering the "ifconfig" command (without the quotes) into the Terminal application (/Applications/Utilities/Terminal) and pressing Return/Enter.

Cheers,
James
Thanks for your response. I saw more openvpn processes running all created by Viscosity. (com.sparklabs.ViscosityHelper (78502))

Finally killing all of them using the below command helped.
sudo killall openvpn

Why does Viscosity spawn so many processed. Had like 5 running.
Hi rosarioarun,

Please ensure you're disconnecting VPN connections when you're finished with them - Viscosity supports connecting multiple VPN connections at once. Please also ensure that you're not Force Quitting Viscosity or any of its components.

Cheers,
James
6 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy