SparkLabs Forum.

Community Help.

After updating to 1.6.8, cannot connect to provider on UDP.

Good afternoon,

I'm running into an issue with Viscosity after updating to 1.6.8. Previously with 1.6.7, I was able to connect to my provider,, on UDP 2049 (or alternatively, UDP 53). After the 1.6.8 update, I'm no longer able to connect to any of their servers on UDP ports, but I can connect on TCP 80 and TCP 443, which are alternative ports they run on.
I'm able to connect to an OpenVPN server on my home network via UDP 1194, but not to my provider on their configured UDP ports. I've tried this from multiple networks (from work, home, a friend's home network, and a coffee shop), and all fail. The info below is an excerpt of the OpenVPN log from a connection:

===== BEGIN LOG =====
Feb 03 13:55:00: Viscosity Mac 1.6.8 (1370)
Feb 03 13:55:00: Viscosity OpenVPN Engine Started
Feb 03 13:55:00: Running on Mac OS X 10.12.3
Feb 03 13:55:00: ---------
Feb 03 13:55:00: Checking reachability status of connection...
Feb 03 13:55:00: Connection is reachable. Starting connection attempt.
Feb 03 13:55:00: OpenVPN 2.3.14 x86_64-apple-darwin [SSL (OpenSSL)] [LZO] [PKCS11] [MH] [IPv6] built on Jan 14 2017
Feb 03 13:55:00: library versions: OpenSSL 1.0.2j 26 Sep 2016, LZO 2.09
Feb 03 13:55:03: Control Channel Authentication: using '/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T/connection.XEWSjg/ta.key' as a OpenVPN static key file
Feb 03 13:55:03: UDPv4 link local: [undef]
Feb 03 13:55:03: UDPv4 link remote: [AF_INET]
Feb 03 13:56:03: TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)
Feb 03 13:56:03: TLS Error: TLS handshake failed
Feb 03 13:56:03: SIGUSR1[soft,tls-error] received, process restarting
Feb 03 13:56:04: TCP/UDP: Preserving recently used remote address: [AF_INET]
Feb 03 13:56:04: UDPv4 link local: [undef]
Feb 03 13:56:04: UDPv4 link remote: [AF_INET]
===== END LOG =====

Any thoughts on what may be causing this? I know your support article, and my provider, seem to think it's firewall related, but I can't see how that's possible if I have tested from 4 different networks to no avail. I know for a fact my home network isn't blocking the ports in question, as I've configured the firewall rules myself on my router/firewall appliance.
Hi billclark,

It's unlikely that being unable to connect is related to the update. It sounds like you've already read our article on this error, however I'll link it again just in case: ... 0-seconds/

As Viscosity performs a reachability check (that is passing) it means it's unlikely your computer itself. Depending on where you're connecting from your internet provider may have started blocking commercial VPN Service Providers connections (TCP connections on port 80 or 443 look more like normal web traffic and so will typically get past such blocking). Another possibility is that your connection settings or certificates are out of date and need to be updated from your VPN Provider - you'll get the same error if the OpenVPN server is flat out rejecting your certificate/key.

2 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy