SparkLabs Forum.

Community Help.


Lost the menu icon and cannot use it anymore :-(

Hello,

I'm on OS X 10.11.6 – after the 1.6.8 upgrade I cannot see the icon anymore and do not know how to use it.

I've killed the app and helper in Activity monitor then deleted the app file, download and installed a new one but the issue is still there :cry:

The system.log shows these errors:

Code: Select all

26/01/17 08:30:43,331 com.apple.xpc.launchd[1]: (com.viscosityvpn.Viscosity.64672[895]) Service exited due to signal: Killed: 9
26/01/17 08:30:51,577 com.apple.xpc.launchd[1]: (com.sparklabs.ViscosityHelper[978]) Service exited due to signal: Killed: 9
26/01/17 08:31:01,337 com.sparklabs.ViscosityHelper[16034]: ViscosityHelper started
26/01/17 08:34:43,957 com.apple.xpc.launchd[1]: (com.viscosityvpn.Viscosity.64672[16033]) Service exited due to signal: Killed: 9
26/01/17 08:34:50,405 com.apple.xpc.launchd[1]: (com.sparklabs.ViscosityHelper[16034]) Service exited due to signal: Killed: 9
26/01/17 08:35:16,000 kernel[0]: hfs: mounted Viscosity on device disk4s1
26/01/17 08:35:16,450 mds[73]: (Volume.Normal:2464) volume:0x7ffed8887000 ********** Bootstrapped Creating a default store:1 SpotLoc:(null) SpotVerLoc:(null) occlude:0 /Volumes/Viscosity
26/01/17 08:35:30,702 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/CrashReporter.framework/CrashReporter
26/01/17 08:35:30,702 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/CrashReporter.framework/Headers
26/01/17 08:35:30,703 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/CrashReporter.framework/Resources
26/01/17 08:35:30,707 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/CrashReporter.framework/Versions/Current
26/01/17 08:35:30,707 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/Growl.framework/Growl
26/01/17 08:35:30,707 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/Growl.framework/Headers
26/01/17 08:35:30,707 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/Growl.framework/Resources
26/01/17 08:35:30,709 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/Growl.framework/Versions/Current
26/01/17 08:35:30,709 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/Sparkle.framework/Headers
26/01/17 08:35:30,709 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/Sparkle.framework/Modules
26/01/17 08:35:30,710 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/Sparkle.framework/PrivateHeaders
26/01/17 08:35:30,710 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/Sparkle.framework/Resources
26/01/17 08:35:30,710 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/Sparkle.framework/Sparkle
26/01/17 08:35:30,724 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/Sparkle.framework/Versions/A/Resources/fr_CA.lproj
26/01/17 08:35:30,728 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/Sparkle.framework/Versions/A/Resources/pt.lproj
26/01/17 08:35:30,736 CoreServicesUIAgent[13391]: error -1 while removing quarantine data on path /Applications/Viscosity.app/Contents/Frameworks/Sparkle.framework/Versions/Current
26/01/17 08:35:37,771 com.sparklabs.ViscosityHelper[16109]: ViscosityHelper started
26/01/17 08:35:47,769 com.apple.xpc.launchd[1]: (com.apple.xpc.launchd.oneshot.0x10000024.Viscosity[16108]) Service exited due to signal: Killed: 9
26/01/17 08:35:56,356 com.apple.xpc.launchd[1]: (com.sparklabs.ViscosityHelper[16109]) Service exited due to signal: Killed: 9
26/01/17 08:37:24,867 com.sparklabs.ViscosityHelper[16147]: ViscosityHelper started


Can you please help me in getting Viscosity back?

Thank you!
Hi hugh,

Try running Viscosity in debug mode. Firstly, make sure it's not running by checking the Activity Monitor. Then start it using the Terminal (/Applications/Utilities/Terminal) by entering the following command and press Return/Enter:

Code: Select all

/Applications/Viscosity.app/Contents/MacOS/Viscosity -DebugMode YES

If you see an error message when Viscosity attempts to start see if it matches the article here:
http://www.sparklabs.com/support/kb/art ... -mac-os-x/

Cheers,
James
Hi James,

no errors in debug mode and still no icon :roll:

Please help!
I have exactly the same issue! Viscosity doesn't work & I can't access my servers! :(
Here's what I see in the terminal:

*** Terminating app due to uncaught exception 'NSInternalInconsistencyException', reason: '/Projects/viscosity-mac/viscosity/Source/main.m:92 main() PyRun_SimpleFile failed with file '/Applications/Viscosity.app/Contents/Resources/main.py'. See console for errors.'
*** First throw call stack:
(
0 CoreFoundation 0x00007fff85f694f2 __exceptionPreprocess + 178
1 libobjc.A.dylib 0x00007fff92ab3f7e objc_exception_throw + 48
2 CoreFoundation 0x00007fff85fd04bd +[NSException raise:format:] + 205
3 Viscosity 0x000000010c3e9cc1 main + 1200
4 libdyld.dylib 0x00007fff89c825ad start + 1
)
libc++abi.dylib: terminating with uncaught exception of type NSException

Any ideas???
no errors in debug mode and still no icon

If there are no errors it means Viscosity is functioning correctly. Check that the icon hasn't been changed (i.e. Viscosity supports a number of different menu icon packs - it may be using a different one from what you're used to). If you use menu bar management software (such as Bartender) please make sure it's not hiding Viscosity. If you're still stuck, backup your connections and do a complete uninstall and reinstall of Viscosity.
http://www.sparklabs.com/support/kb/art ... -settings/
http://www.sparklabs.com/support/kb/art ... osity-mac/

I have exactly the same issue! Viscosity doesn't work & I can't access my servers!

Your issue appears to be different - Viscosity is crashing as there is a problem with the Python framework on your machine. Please see:
http://www.sparklabs.com/support/kb/art ... -mac-os-x/

Cheers,
James
Hello James,

I'hr done nothing and it magically reappeared!

FYI I do not use any use menu bar management software.

Thank you!
I'm seeing similar behavior on occasion. It's not consistent, but sometimes the menu icon will be gone. In my case though, I am using a menu bar tool (Bartender), so I see the blank space where the icon should be. In each instance this has occurred, killing the Viscosity app and helper daemon from the shell and then restarting Viscosity has solved the issue. But it's odd its happening after 1.6.8, but not before.

Just wanted to make sure SparkLabs was aware. It's not a huge problem for me as restarting the app resolves the issue.

Thanks.
8 posts Page 1 of 1

Copyright © 2016 SparkLabs Pty Ltd. All Rights Reserved. Privacy Policy