Hi there,

with the recent update of Viscosity, I can't connect to my VPN network anymore. The log output is:

Code: Select all

Jun 22 18:21:34: Viscosity Mac 1.5.7 (1290)
Jun 22 18:21:34: Viscosity OpenVPN Engine Started
Jun 22 18:21:34: Running on Mac OS X 10.10.3
Jun 22 18:21:34: ---------
Jun 22 18:21:34: Checking reachability status of connection...
Jun 22 18:21:34: Connection is reachable. Starting connection attempt.
Jun 22 18:21:34: OpenVPN 2.3.7 x86_64-apple-darwin [SSL (OpenSSL)] [LZO] [PKCS11] [MH] [IPv6] built on Jun 13 2015
Jun 22 18:21:34: library versions: OpenSSL 1.0.2c 12 Jun 2015, LZO 2.09
Jun 22 18:21:37: WARNING: No server certificate verification method has been enabled.  See http://openvpn.net/howto.html#mitm for more info.
Jun 22 18:21:37: WARNING: normally if you use --mssfix and/or --fragment, you should also set --tun-mtu 1500 (currently it is 1492)
Jun 22 18:21:37: UDPv4 link local: [undef]
Jun 22 18:21:37: UDPv4 link remote: [AF_INET]178.26.9.107:1194
Jun 22 18:21:37: WARNING: this configuration may cache passwords in memory -- use the auth-nocache option to prevent this
Jun 22 18:21:37: TLS_ERROR: BIO read tls_read_plaintext error: error:14082174:SSL routines:ssl3_check_cert_and_algorithm:dh key too small
Jun 22 18:21:37: TLS Error: TLS object -> incoming plaintext read error
Jun 22 18:21:37: TLS Error: TLS handshake failed
Jun 22 18:21:37: SIGUSR1[soft,tls-error] received, process restarting


As I've read here this may have something to do with the recent update of OpenSSL.
Since I can't change the key length(to 1024/2048) either, I'd like to downgrade to the previous version of Viscosity (1.5.6). Unfortunately, I couldn't find this version in the download section. Could you please send me a link to the previous version?

Thanks